Задание EGEINF90D64F: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите количество строк таблицы, для чисел которых выполнены оба условия:

– в строке есть два числа, каждое из которых повторяется дважды, остальные три числа различны;

– среднее арифметическое неповторяющихся чисел строки больше среднего арифметического всех её повторяющихся чисел.

В ответе запишите только число.

Скачать файл задания (ODS, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
4.2 Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц
4.4 Вероятностные модели. Методы Монте-Карло. Имитационное моделирование. Системы массового обслуживания
Тип ответа:Краткий ответ
Номер: 90D64F
НЕ РЕШЕНО Ответить

Решение задания EGEINF90D64F

Ответ: 96

Решение.
В приложенном файле 16000 строк по 7 натуральных чисел; первая строка уже содержит данные. Проверяем строки независимо и сохраняем их исходную нумерацию.
Требуется ровно пять различных значений: два встречаются по два раза, три — по одному. Отсортированный список частот равен [1, 1, 1, 2, 2]. Только после этой проверки рассматриваем второе условие.
Пусть R — сумма всех четырёх ячеек с повторяющимися значениями, U — сумма трёх неповторяющихся. Повторяющиеся числа включаем в R с обоими вхождениями.
Среднее неповторяющихся больше среднего повторяющихся: U3 > R4. Умножаем на положительное 12: 4U > 3R. Так избегаем погрешности вычисления средних.
Для воспроизводимого подсчёта сохраним заполненный лист как текст с разделителями табуляции под именем data.txt в кодировке UTF-8. Заголовок добавлять не нужно. При экспорте должны сохраниться все 16000 строк и все 7 чисел каждой строки. Метод split() разбирает как табуляции, так и пробелы.
Следующая программа проверяет оба требования для каждой строки:

from collections import Counter

answer = 0
with open("data.txt", encoding="utf-8-sig") as f:
    for number, line in enumerate(f, 1):
        a = sorted(map(int, line.split()))
        c = Counter(a)
        single = [x for x in a if c[x] == 1]
        repeat = [x for x in a if c[x] > 1]
        ok = (sorted(c.values()) == [1, 1, 1, 2, 2] and 4 * sum(single) > 3 * sum(repeat))
        if ok:
            answer += 1
print(answer)

Counter хранит частоту каждого значения. Оператор and означает одновременное выполнение условий; если проверка частот не прошла, второе выражение не вычисляется.
Каждая строка учитывается не более одного раза. Полный проход даёт 96 подходящих строк.
Контроль нескольких найденных строк:

Номер строкиЗначения
11128, 30, 18, 18, 33, 33, 44
78742, 48, 38, 57, 17, 42, 17
134079, 67, 62, 67, 91, 44, 62
1512975, 47, 94, 19, 67, 19, 67
1518139, 50, 50, 88, 81, 12, 39

Например, строка 111: Частоты значений равны [1, 1, 1, 2, 2]; неповторяющиеся: [28, 30, 44], повторяющиеся с учётом всех вхождений: [18, 18, 33, 33]. Их суммы U = 102, R = 102. 4U = 408 > 3R = 306.
Проверка выполнена также по исходному XLSX: независимый алгоритм подсчёта частот совпал по всем выбранным номерам строк.
Ответ: 96.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF90D64F.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.