Задание EGEINF4E04E7: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

Рассматривается множество целых чисел, принадлежащих числовому отрезку [14 014; 48 235], которые делятся на 5 или 6
и не делятся на 10, 11, 13. Найдите количество таких чисел
и максимальное из них.

В ответе запишите два целых числа: сначала количество, затем максимальное число.

Для выполнения этого задания можно написать программу или воспользоваться редактором электронных таблиц.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.6 Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования
Тип ответа:Краткий ответ
Номер: 4E04E7
НЕ РЕШЕНО Ответить

Решение задания EGEINF4E04E7

Ответ: 6703 48234

Решение.
Перебираем все целые n от 14014 до 48235 включительно. Число подходит, если есть делимость хотя бы на одно из чисел 5, 6, и одновременно оно не делится ни на одно из чисел 10, 11, 13. Все запреты нужно соединить логическим «И».
В Python остаток даёт операция %. Условие равенства нулю проверяет делимость; неравенство нулю исключает её. Счётчик увеличиваем только после проверки полного условия. Каждое число посещается один раз, поэтому совпадение нескольких признаков не приводит к повторному подсчёту.
Полная программа на Python 3:

count = 0
best = None
for n in range(14014, 48236):
    if (n % 5 == 0 or n % 6 == 0) and n % 10 != 0 and n % 11 != 0 and n % 13 != 0:
        count += 1
        if best is None or n > best:
            best = n
print(count, best)

Программа выводит 6703 48234. Верхний предел range равен 48236, чтобы число 48235 не потерялось. В ответе сначала идёт количество, затем максимум.
Независимая проверка количества. Все признаки зависят только от остатков по указанным делителям. Их наименьшее общее кратное L = 4290, поэтому набор подходящих остатков повторяется через L чисел. В блоке от 1 до L подходящих чисел 840.
Обозначим C(N) количество подходящих чисел от 1 до N. Если N = qL + r, то C(N) равно числу полных блоков, умноженному на число подходящих остатков в блоке, плюс число подходящих остатков от 1 до r.

NПолные блоки qОстаток rПодходящих в остаткеC(N)
14013311432232743
482351110452069446

На заданном отрезке C(48235) − C(14013) = 9446 − 2743 = 6703.
Проверка границы. Первые подходящие числа: 14015, 14016, 14022, 14028, 14034. Последние: 48216, 48222, 48225, 48228, 48234.
Для числа 48234: остаток при делении на 5 равен 4, остаток при делении на 6 равен 0, остаток при делении на 10 равен 4, остаток при делении на 11 равен 10, остаток при делении на 13 равен 4. Оно принадлежит отрезку и проходит все условия. Между ним и соответствующим концом отрезка проверены все целые числа; подходящих среди них нет. Поэтому найденный максимум подтверждён.
Ответ: 6703 48234.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF4E04E7.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.