Задание EGEINF0AD095: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

Рассматривается множество целых чисел, принадлежащих числовому отрезку [12 014; 49 635], остаток от деления которых
на 13 равен 7, и при этом они  не делятся ни на 5, ни на 12. Найдите количество таких чисел и минимальное из них.

В ответе запишите два целых числа: сначала количество, затем минимальное число.

Для выполнения этого задания можно написать программу или воспользоваться редактором электронных таблиц.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.6 Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования
Тип ответа:Краткий ответ
Номер: 0AD095
НЕ РЕШЕНО Ответить

Решение задания EGEINF0AD095

Ответ: 2122 12019

Решение.
Перебираем все целые n от 12014 до 49635 включительно. Число подходит, если остаток при делении на 13 равен 7, и одновременно оно не делится ни на одно из чисел 5, 12. Все запреты нужно соединить логическим «И».
В Python остаток даёт операция %. Условие равенства нулю проверяет делимость; неравенство нулю исключает её. Счётчик увеличиваем только после проверки полного условия. Каждое число посещается один раз, поэтому совпадение нескольких признаков не приводит к повторному подсчёту.
Полная программа на Python 3:

count = 0
best = None
for n in range(12014, 49636):
    if n % 13 == 7 and n % 5 != 0 and n % 12 != 0:
        count += 1
        if best is None or n < best:
            best = n
print(count, best)

Программа выводит 2122 12019. Верхний предел range равен 49636, чтобы число 49635 не потерялось. В ответе сначала идёт количество, затем минимум.
Независимая проверка количества. Все признаки зависят только от остатков по указанным делителям. Их наименьшее общее кратное L = 780, поэтому набор подходящих остатков повторяется через L чисел. В блоке от 1 до L подходящих чисел 44.
Обозначим C(N) количество подходящих чисел от 1 до N. Если N = qL + r, то C(N) равно числу полных блоков, умноженному на число подходящих остатков в блоке, плюс число подходящих остатков от 1 до r.

NПолные блоки qОстаток rПодходящих в остаткеC(N)
120131531317677
4963563495272799

На заданном отрезке C(49635) − C(12013) = 2799 − 677 = 2122.
Проверка границы. Первые подходящие числа: 12019, 12032, 12058, 12071, 12097. Последние: 49563, 49576, 49589, 49602, 49628.
Для числа 12019: остаток при делении на 13 равен 7, остаток при делении на 5 равен 4, остаток при делении на 12 равен 7. Оно принадлежит отрезку и проходит все условия. Между ним и соответствующим концом отрезка проверены все целые числа; подходящих среди них нет. Поэтому найденный минимум подтверждён.
Ответ: 2122 12019.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF0AD095.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.