Задание EGEINF2810ED: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

 

Рассматривается множество целых чисел, принадлежащих числовому отрезку [16 015; 48 989], которые делятся на 7 или 11 и не делятся на 9, 12, 13. Найдите количество таких чисел и минимальное из них.

В ответе запишите два целых числа: сначала количество, затем минимальное число.

Для выполнения этого задания можно написать программу или воспользоваться редактором электронных таблиц.

 

Ответ:

 

 

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 2810ED
НЕ РЕШЕНО Ответить

Решение задания EGEINF2810ED

Ответ: 5598 16023

Решение.
Перебираем все целые n от 16015 до 48989 включительно. Число подходит, если есть делимость хотя бы на одно из чисел 7, 11, и одновременно оно не делится ни на одно из чисел 9, 12, 13. Все запреты нужно соединить логическим «И».
В Python остаток даёт операция %. Условие равенства нулю проверяет делимость; неравенство нулю исключает её. Счётчик увеличиваем только после проверки полного условия. Каждое число посещается один раз, поэтому совпадение нескольких признаков не приводит к повторному подсчёту.
Полная программа на Python 3:

count = 0
best = None
for n in range(16015, 48990):
    if (n % 7 == 0 or n % 11 == 0) and n % 9 != 0 and n % 12 != 0 and n % 13 != 0:
        count += 1
        if best is None or n < best:
            best = n
print(count, best)

Программа выводит 5598 16023. Верхний предел range равен 48990, чтобы число 48989 не потерялось. В ответе сначала идёт количество, затем минимум.
Независимая проверка количества. Все признаки зависят только от остатков по указанным делителям. Их наименьшее общее кратное L = 36036, поэтому набор подходящих остатков повторяется через L чисел. В блоке от 1 до L подходящих чисел 6120.
Обозначим C(N) количество подходящих чисел от 1 до N. Если N = qL + r, то C(N) равно числу полных блоков, умноженному на число подходящих остатков в блоке, плюс число подходящих остатков от 1 до r.

NПолные блоки qОстаток rПодходящих в остаткеC(N)
1601401601427212721
4898911295321998319

На заданном отрезке C(48989) − C(16014) = 8319 − 2721 = 5598.
Проверка границы. Первые подходящие числа: 16023, 16027, 16030, 16037, 16049. Последние: 48961, 48965, 48979, 48983, 48986.
Для числа 16023: остаток при делении на 7 равен 0, остаток при делении на 11 равен 7, остаток при делении на 9 равен 3, остаток при делении на 12 равен 3, остаток при делении на 13 равен 7. Оно принадлежит отрезку и проходит все условия. Между ним и соответствующим концом отрезка проверены все целые числа; подходящих среди них нет. Поэтому найденный минимум подтверждён.
Ответ: 5598 16023.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF2810ED.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.