Задание EGEINFFA6C24: Пары и тройки в числовых данных

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Пары и тройки в числовых данных.

Учебные темы: Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых файлов.

В файле содержится последовательность целых чисел. Её элементы могут принимать целые значения от –100 000 до 100 000 включительно. Определите количество троек элементов последовательности, в которых не более двух из трёх элементов являются четырёхзначными числами, а сумма элементов тройки не больше максимального элемента последовательности, оканчивающегося на 25. В ответе запишите количество найденных троек чисел, затем максимальную из сумм элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента последовательности.

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.10 Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве
Тип ответа:Краткий ответ
Номер: FA6C24
НЕ РЕШЕНО Ответить

Решение задания EGEINFFA6C24

Ответ: 6315 84523

Решение.
В файле 6679 чисел. Тройка — только три соседних элемента; произвольные сочетания из файла не рассматриваем. Соседние тройки могут иметь общие элементы, и каждая проверяется отдельно.

Сначала по всей последовательности находим M — наибольшее значение среди чисел, десятичная запись которых оканчивается на 25. Проверка окончания: abs(x) % 100 == 25. Модуль нужен только для цифр записи; сам максимум берём по исходным значениям, сохраняя знак. Из файла получаем M = 84725.

Число имеет 4 цифр тогда и только тогда, когда 1000 ≤ |x| < 10000. Знак минуса не является цифрой, а правая граница не включается. В каждой тройке считаем k — количество элементов с таким числом цифр. По условию требуется не более двух: проверяем k <= 2.

После проверки количества цифр находим обычную сумму трёх исходных чисел S, с их знаками. Второе условие: S ≤ M. Равенство допускается. Если обе проверки пройдены, увеличиваем счётчик и обновляем наибольшую подходящую сумму. Начальное значение максимума — None, чтобы не предполагать положительность ответа.

Все начала троек имеют индексы от 0 до N − 3 включительно. Поэтому range(len(a) - 2) проверяет каждую тройку ровно один раз и не выходит за конец файла.

Программа Python; data.txt — исходный текстовый файл из архива:

with open("data.txt", encoding="utf-8-sig") as f:
    a = list(map(int, f.read().split()))
M = max(x for x in a if abs(x) % 100 == 25)
count = 0
best = None
for i in range(len(a) - 2):
    triple = a[i:i + 3]
    k = sum(1000 <= abs(x) < 10000 for x in triple)
    total = sum(triple)
    if k <= 2 and total <= M:
        count += 1
        if best is None or total > best:
            best = total
print(count, best)

Получаем 6315 подходящих троек; наибольшая сумма равна 84523.

Проверка максимума. В тройке с первым элементом на позиции 205 (нумерация от 1) стоят числа -682, 85871, -666. Их сумма (-682) + 85871 + (-666) = 84523. Эта тройка удовлетворяет обоим условиям. Независимый проход по всем окнам подтвердил и количество, и максимальную сумму; существование одного примера не заменяет полный перебор.

Сложность двух проходов линейная по количеству чисел; внутри каждой тройки выполняется постоянное число операций.

Ответ: 6315 84523.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINFFA6C24.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.