Задание EGEINF0A2C26: Пары и тройки в числовых данных

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Пары и тройки в числовых данных.

Учебные темы: Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых файлов.

 

В файле содержится последовательность натуральных чисел.
Её элементы могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности,
в которых сумма остатков от деления обоих элементов
на 12 равна минимальному элементу последовательности. В ответе запишите количество найденных пар, затем минимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

 

Рисунок из условия ФИПИ


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.10 Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве
Тип ответа:Краткий ответ
Номер: 0A2C26
НЕ РЕШЕНО Ответить

Решение задания EGEINF0A2C26

Ответ: 639 3716

Решение.
Считываем исходный текстовый файл как последовательность целых чисел, сохраняя их порядок. В нём 10000 элементов; первой строки с количеством элементов нет.
Парой считаются только соседние элементы. При индексации Python от нуля перебираем i от 0 до len(a) − 2 и берём a[i], a[i + 1]. Всего проверяем 9999 пар. Пары могут пересекаться, а каждое начало рассматривается ровно один раз.
Первым проходом находим минимальный элемент всего файла: m = 8. Он стоит на позиции 9564 при нумерации от единицы. Здесь минимум берётся по всем элементам, до отбора пар.
Для каждой соседней пары x, y проверяем x mod 12 + y mod 12 = m. Сумма двух отдельных остатков может отличаться от остатка суммы, поэтому не заменяем это условие на (x + y) mod 12 = m.
У всех подходящих пар считаем сумму самих чисел x + y; выбираем минимальную такую сумму.
После обработки очередной пары count равно числу подходящих пар среди уже проверенных, а best хранит требуемую крайнюю сумму среди них. Для первой подходящей пары присваиваем её сумму; затем обновляем best. Начальное значение None позволяет корректно работать и с отрицательными суммами.
Сохраните скачанный файл рядом с программой под его исходным именем. Программа на Python:

with open("img1_1786621611.txt") as f:
    a = [int(line) for line in f]
m = min(a)
count = 0
best = None
for i in range(len(a) - 1):
    x, y = a[i], a[i + 1]
    if x % 12 + y % 12 == m:
        count += 1
        s = x + y
        best = s if best is None else min(best, s)
print(count, best)

Перебор исходного файла даёт count = 639, best = 3716.
Проверка: крайняя сумма достигается на соседних позициях 3505 и 3506: x = 943, y = 2773, x + y = 3716.
Остатки равны 7 и 1; их сумма 7 + 1 = 8, поэтому пара подходит.
Независимый повторный проход подтвердил все индексы отобранных пар, их количество и крайнюю сумму. Других соседних пар нет: диапазон начал охватывает весь файл без пропусков.
Поиск порога и просмотр пар требуют линейного времени O(n). Массив занимает O(n) памяти; счётчик и текущая крайняя сумма — постоянный объём.
Ответ: 639 3716.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF0A2C26.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.