Задание EGEINFC9738B: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Откройте файл электронной таблицы, содержащей в каждой строке три натуральных числа. Определите количество строк таблицы, в которых квадрат максимального из трёх чисел больше удвоенного произведения двух других чисел в строке.

Скачать файл задания (ODS, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
4.2 Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц
4.4 Вероятностные модели. Методы Монте-Карло. Имитационное моделирование. Системы массового обслуживания
Тип ответа:Краткий ответ
Номер: C9738B
НЕ РЕШЕНО Ответить

Решение задания EGEINFC9738B

Ответ: 2715

Решение.
В приложенном файле 3200 строк по 3 натуральных чисел; первая строка уже содержит данные. Проверяем строки независимо и сохраняем их исходную нумерацию.
Пусть после сортировки a ≤ b ≤ c. Условие принимает вид c² > 2ab. Сравнение строгое; равенство не учитываем.
Максимальное значение выбирается в одном вхождении. Поэтому при повторении максимума второе такое число остаётся среди двух остальных.
Для воспроизводимого подсчёта сохраним заполненный лист как текст с разделителями табуляции под именем data.txt в кодировке UTF-8. Заголовок добавлять не нужно. При экспорте должны сохраниться все 3200 строк и все 3 чисел каждой строки. Метод split() разбирает как табуляции, так и пробелы.
Следующая программа проверяет оба требования для каждой строки:

from collections import Counter

answer = 0
with open("data.txt", encoding="utf-8-sig") as f:
    for number, line in enumerate(f, 1):
        a = sorted(map(int, line.split()))
        c = Counter(a)
        single = [x for x in a if c[x] == 1]
        repeat = [x for x in a if c[x] > 1]
        ok = (a[-1] ** 2 > 2 * a[0] * a[1])
        if ok:
            answer += 1
print(answer)

Counter хранит частоту каждого значения. Оператор and означает одновременное выполнение условий; если проверка частот не прошла, второе выражение не вычисляется.
Каждая строка учитывается не более одного раза. Полный проход даёт 2715 подходящих строк.
Контроль нескольких найденных строк:

Номер строкиЗначения
143, 82, 21
296, 79, 29
389, 44, 50
319926, 91, 47
320051, 4, 2

Например, строка 1: 82² = 6724; удвоенное произведение двух остальных равно 1806. Строгое неравенство выполнено.
Проверка выполнена также по исходному XLSX: независимый алгоритм подсчёта частот совпал по всем выбранным номерам строк.
Ответ: 2715.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINFC9738B.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.