Задание EGEINF9D0AA0: Поиск ошибок в программе

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Поиск ошибок в программе.

Учебные темы: Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования.

Дайте развернутый ответ.

На обработку поступает натуральное число, не превышающее 109. Нужно написать программу, которая выводит на экран максимальную чётную цифру этого числа. Если в числе нет чётных цифр, требуется на экран вывести «NO». Программист написал программу неправильно. Ниже эта программа для Вашего удобства приведена на пяти языках программирования.

Бейсик

Python

DIM N, DIGIT, MAXDIGIT AS LONG

INPUT N

MAXDIGIT = N MOD 10

WHILE N > 0

  DIGIT = N MOD 10

  IF DIGIT MOD 2 = 0 THEN

    IF DIGIT > MAXDIGIT THEN

      DIGIT = MAXDIGIT

    END IF

  END IF

  N = N \ 10

WEND

IF MAXDIGIT >= 0 THEN

  PRINT MAXDIGIT

ELSE

  PRINT "NO"

END IF

N = int(input())

maxDigit = N % 10

while N > 0:

  digit = N % 10

  if digit % 2 == 0:

    if digit > maxDigit:

      digit = maxDigit

  N = N // 10

if maxDigit >= 0:

  print(maxDigit)

else:

  print("NO")

Алгоритмический язык

Паскаль

алг

нач

  цел N, digit, maxDigit

  ввод N

  maxDigit := mod(N,10)

  нц пока N > 0

    digit := mod(N,10)

    если mod(digit, 2) = 0 то

      если digit > maxDigit то

        digit := maxDigit

      все

    все

    N := div(N,10)

  кц

  если maxDigit >= 0 то

    вывод maxDigit

  иначе

    вывод "NO"

  все

кон

var N,digit,maxDigit: longint;

begin

  readln(N);

  maxDigit := N mod 10;

  while N > 0 do

  begin

    digit := N mod 10;

    if digit mod 2 = 0 then

      if digit > maxDigit then

        digit := maxDigit;

    N := N div 10;

  end;

  if maxDigit >= 0 then

    writeln(maxDigit)

  else

    writeln('NO')

end.

С++

#include <iostream>

using namespace std;

 

int main() {

  int N, digit, maxDigit;

  cin >> N;

  maxDigit = N % 10;

  while (N > 0) {

    digit = N % 10;

    if (digit % 2 == 0)

      if (digit > maxDigit)

        digit = maxDigit;

    N = N / 10;

  }

  if (maxDigit >= 0)

    cout << maxDigit << endl;

  else

    cout << "NO" << endl;

  return 0;

}

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе числа 243.

2. Приведите пример такого трёхзначного числа, при вводе которого приведённая программа, несмотря на ошибки, выдаёт верный ответ.

3. Найдите допущенные программистом ошибки и исправьте их. Исправление ошибки должно затрагивать только строку, в которой находится ошибка. Для каждой ошибки:

1) выпишите строку, в которой сделана ошибка;

2) укажите, как исправить ошибку, т.е. приведите правильный вариант строки.

Известно, что в тексте программы можно исправить ровно две строки так, чтобы она стала работать правильно.

Достаточно указать ошибки и способ их исправления для одного языка программирования.

Обратите внимание на то, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения.


 

i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.6 Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования
Тип ответа:Развернутый ответ
Номер: 9D0AA0
НЕ РЕШЕНО Изменить статус

Решение задания EGEINF9D0AA0

Ответ: 1) 3; 2) 246; 3) maxDigit = −1; maxDigit = digit

На обработку поступает натуральное число, не превышающее 10⁹. Нужно написать программу, которая выводит на экран максимальную чётную цифру этого числа. Если в числе нет чётных цифр, требуется на экран вывести «NO».

1. Выполнение исходной ошибочной программы.
Ввод: 243.
Шаг 1: N = 243, извлекается цифра 3; maxDigit = 3; после удаления последней цифры N = 24.
Шаг 2: N = 24, извлекается цифра 4; maxDigit = 3; после удаления последней цифры N = 2. Ошибочное присваивание изменяет digit на 3, но искомый экстремум не обновляет.
Шаг 3: N = 2, извлекается цифра 2; maxDigit = 3; после удаления последней цифры N = 0.
Вывод программы: 3.
Этот вывод относится именно к исходному коду. Требуемый по условию результат для тех же данных: 4.

2. Пример, на котором исходная программа случайно даёт верный ответ.
Возьмём 246.
Шаг 1: N = 246, извлекается цифра 6; maxDigit = 6; после удаления последней цифры N = 24.
Шаг 2: N = 24, извлекается цифра 4; maxDigit = 6; после удаления последней цифры N = 2.
Шаг 3: N = 2, извлекается цифра 2; maxDigit = 6; после удаления последней цифры N = 0.
Вывод исходной программы: 6.
Подходящие цифры: 2, 4, 6. По условию получается 6, что совпадает с фактическим выводом.

3. Исправление ровно двух строк: Python.
Все остальные строки и отступы сохраняются.

Ошибка 1. Строка в исходной программе:

maxDigit = N % 10

Правильная строка:

maxDigit = -1

Начальное значение −1 меньше любой десятичной цифры и не является цифрой. Ноль может быть верным результатом, а последняя цифра может не удовлетворять условию отбора.

Ошибка 2. Строка в исходной программе:

      digit = maxDigit

Правильная строка:

      maxDigit = digit

Найденную подходящую цифру нужно сохранять в переменной экстремума. Обратное присваивание меняет временную digit, а накопленный результат оставляет прежним.

Проверка исправленной программы.
После обработки любого количества последних цифр накопленная переменная хранит максимум подходящих значений этой части.
Вначале обработанных значений нет: используется начальная граница −1. При неподходящем значении экстремум не меняется. При подходящем значение сравнивается с сохранённым: большее заменяет максимум. Поэтому утверждение сохраняется на каждом шаге.
После каждого шага последняя цифра удаляется целочисленным делением на 10. Положительное N уменьшается до 0, поэтому будут рассмотрены все цифры ровно по одному разу; при N ≤ 10⁹ требуется не более десяти шагов.
Если подходящих цифр не было, сохраняется начальный признак отсутствия результата; иначе сохранена допустимая цифра от 0 до 9. Заключительное ветвление различает эти два случая.
Для исходного ввода 243 исправленная программа выводит 4.
Необходимость исправления 1: если оставить только эту ошибку, при вводе 1 получится 1 вместо «NO».
Необходимость исправления 2: если оставить только эту ошибку, при вводе 2 получится «NO» вместо 2.

Ответ: 1) 3; 2) 246; 3) maxDigit = −1; maxDigit = digit.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF9D0AA0.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.