Задание EGEINF6D2D86: Делители, маски и отбор чисел

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Делители, маски и отбор чисел.

Учебные темы: Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена».

Впишите правильный ответ.

Пусть M –  сумма минимального и максимального натуральных делителей целого числа, не считая единицы и самого числа. Если таких делителей у числа нет, то считаем значение M равным нулю.

Напишите программу, которая перебирает целые числа, большие 452 021, в порядке возрастания и ищет среди них такие, для которых значение M при делении на 7 даёт в остатке 3. Вывести первые
5 найденных чисел и соответствующие им значения M.

Формат вывода: для каждого из 5 таких найденных чисел
в отдельной строке сначала выводится само число, затем –
значение М.

Строки выводятся в порядке возрастания найденных чисел.

 

Например, для числа 20 М = 2 + 10 = 12.

 

Количество строк в таблице для ответа избыточно.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
2.13 Графы. Основные понятия. Виды графов. Описание графов с помощью матриц смежности, весовых матриц, списков смежности. Решение алгоритмических задач, связанных с анализом графов (построение оптимального пути между вершинами графа, определение количества различных путей между вершинами ориентированного ациклического графа)
2.14 Деревья. Бинарное дерево. Деревья поиска. Способы обхода дерева. Представление арифметических выражений в виде дерева. Использование графов и деревьев при описании объектов и процессов окружающего мира
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.10 Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве
3.11 Двумерные массивы (матрицы). Алгоритмы обработки двумерных массивов: заполнение двумерного числового массива по заданным правилам, поиск элемента в двумерном массиве, вычисление максимума (минимума) и суммы элементов двумерного массива, перестановка строк и столбцов двумерного массива
3.12 Словари (ассоциативные массивы, отображения). Хэш-таблицы. Построение алфавитно-частотного словаря для заданного текста
3.13 Стеки. Анализ правильности скобочного выражения. Вычисление арифметического выражения, записанного в постфиксной форме. Очереди. Использование очереди для временного хранения данных
3.14 Алгоритмы на графах. Построение минимального остовного дерева взвешенного связного неориентированного графа. Количество различных путей между вершинами ориентированного ациклического графа. Алгоритм Дейкстры
3.15 Деревья. Реализация дерева с помощью ссылочных структур. Двоичные (бинарные) деревья. Построение дерева для заданного арифметического выражения. Рекурсивные алгоритмы обхода дерева. Использование стека и очереди для обхода дерева
Тип ответа:Краткий ответ
Номер: 6D2D86
НЕ РЕШЕНО Ответить

Решение задания EGEINF6D2D86

Ответ: (452025; 150678), (452029; 23810), (452034; 226019), (452048; 226026), (452062; 226033)

Решение.
Требуются первые пять чисел, строго больших 452021. Начинаем с 452022 и рассматриваем целые n подряд в порядке возрастания.
Для каждого целого d от 2 до ⌊√n⌋ проверяем остаток при делении n на d. При нулевом остатке добавляем d и парный делитель nd. Множество устраняет повторение в случае d² = n.
Это полный список делителей без 1 и n: в любой паре сомножителей хотя бы один не больше √n. Поэтому каждую пару находим, в том числе пары с большим вторым делителем.
Если список пуст, M = 0. Иначе берём его минимум p и максимум q, получаем M = p + q. Дополнительная проверка: q = np, поскольку при увеличении положительного делителя парный сомножитель уменьшается. Для квадрата простого числа минимум и максимум равны и складываются дважды.
Требуемое условие: остаток от деления M на 7 равен 3.
n = 452025: минимальный делитель 3, максимальный 150675; 3 · 150675 = 452025.
M = 3 + 150675 = 150678; 150678 = 7 · 21525 + 3.
n = 452029: минимальный делитель 19, максимальный 23791; 19 · 23791 = 452029.
M = 19 + 23791 = 23810; 23810 = 7 · 3401 + 3.
n = 452034: минимальный делитель 2, максимальный 226017; 2 · 226017 = 452034.
M = 2 + 226017 = 226019; 226019 = 7 · 32288 + 3.
n = 452048: минимальный делитель 2, максимальный 226024; 2 · 226024 = 452048.
M = 2 + 226024 = 226026; 226026 = 7 · 32289 + 3.
n = 452062: минимальный делитель 2, максимальный 226031; 2 · 226031 = 452062.
M = 2 + 226031 = 226033; 226033 = 7 · 32290 + 3.
Полный последовательный перебор от 452022 до 452062 включительно проверяет 41 чисел. Условие выполняется ровно для пяти перечисленных n. Все меньшие допустимые кандидаты проверены, поэтому это именно первые пять чисел.
Проверка результата.
Воспроизводимая программа Python:

from math import isqrt

def proper_divisors(n):
    result = set()
    for d in range(2, isqrt(n) + 1):
        q, r = divmod(n, d)
        if r == 0:
            result.update((d, q))
    return sorted(result)

n = 452021
found = 0
while found != 5:
    n += 1
    d = proper_divisors(n)
    value = d[0] + d[-1] if d else 0
    ok = value % 7 == 3
    if ok:
        print(n, value)
        found += 1

Результат: в каждой строке слева n, справа M.
452025 — 150678
452029 — 23810
452034 — 226019
452048 — 226026
452062 — 226033
Ответ: (452025; 150678), (452029; 23810), (452034; 226019), (452048; 226026), (452062; 226033).

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF6D2D86.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.