Задание EGEINF55A68F: Делители, маски и отбор чисел

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Делители, маски и отбор чисел.

Учебные темы: Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена».

Впишите правильный ответ.

Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:

–       символ «?» означает ровно одну произвольную цифру;

–       символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать
и пустую последовательность.

Например, маске 123*4?5 соответствуют числа 123405 и 12300405.

Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 1*23?9, делящиеся на 2023 без остатка.

В ответе запишите в первом столбце таблицы все найденные числа
в порядке возрастания, а во втором столбце – соответствующие результаты деления этих чисел на 2023.

Количество строк в таблице для ответа избыточно.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 55A68F
НЕ РЕШЕНО Ответить

Решение задания EGEINF55A68F

Ответ: (1442399; 713), (11112339; 5493), (12872349; 6363), (14632359; 7233), (16392369; 8103), (18152379; 8973), (19912389; 9843)

Решение.
Ищем все натуральные n, удовлетворяющие маске 1*23?9, ограничению n ≤ 10⁸ и делимости на 2023.
Каждый знак «?» заменяется ровно одной десятичной цифрой. Звёздочка допускает пустую строку и строки с нулями в начале: эти нули находятся внутри записи числа и должны сохраняться.
Без звёздочки в маске 5 позиций, из них 1 обозначены знаком «?». Граница 10⁸ отдельно проверяется по маске и ей не соответствует. Все остальные допустимые числа содержат не более 8 цифр.
Поэтому длина замены «*» принимает все целые значения от 0 до 3. При длине k имеется 10¹ · 10ᵏ подстановок.
Общее число подстановок: 10 + 100 + 1000 + 10000 = 11110.
Первый символ маски — фиксированная ненулевая цифра. Подстановки дают натуральные числа без ведущего нуля; различные наборы замен дают разные записи. Перебор длин и всех цифр охватывает каждое допустимое число.
Для каждого кандидата вычисляем частное и остаток при делении на 2023. Оставляем ровно те числа, у которых остаток равен нулю, затем упорядочиваем их по числовому значению.
Найденные числа и проверка каждой строки:
n = 1442399: значения «?» слева направо: 9; «*» = «44».
2023 · 713 = 1442399; остаток 0.
n = 11112339: значения «?» слева направо: 3; «*» = «111».
2023 · 5493 = 11112339; остаток 0.
n = 12872349: значения «?» слева направо: 4; «*» = «287».
2023 · 6363 = 12872349; остаток 0.
n = 14632359: значения «?» слева направо: 5; «*» = «463».
2023 · 7233 = 14632359; остаток 0.
n = 16392369: значения «?» слева направо: 6; «*» = «639».
2023 · 8103 = 16392369; остаток 0.
n = 18152379: значения «?» слева направо: 7; «*» = «815».
2023 · 8973 = 18152379; остаток 0.
n = 19912389: значения «?» слева направо: 8; «*» = «991».
2023 · 9843 = 19912389; остаток 0.
Проверены все 11110 подстановок и отдельно верхняя граница; найдено 7 подходящих чисел. Других замен маски в допустимом диапазоне нет.
Проверка результата.
Воспроизводимая программа Python:

from itertools import product
from fnmatch import fnmatchcase

mask = '1*23?9'
limit = 10 ** 8
divisor = 2023
fixed = len(mask.replace('*', ''))
lengths = range(8 - fixed + 1) if '*' in mask else [0]
numbers = set()
for length in lengths:
    pattern = mask.replace('*', '?' * length)
    for digits in product('0123456789', repeat=pattern.count('?')):
        it = iter(digits)
        text = ''.join(next(it) if c == '?' else c for c in pattern)
        numbers.add(int(text))
if fnmatchcase(str(limit), mask):
    numbers.add(limit)
for n in sorted(numbers):
    quotient, remainder = divmod(n, divisor)
    if remainder == 0:
        print(n, quotient)

Результат: в каждой строке слева n, справа частное.
1442399 — 713
11112339 — 5493
12872349 — 6363
14632359 — 7233
16392369 — 8103
18152379 — 8973
19912389 — 9843
Ответ: (1442399; 713), (11112339; 5493), (12872349; 6363), (14632359; 7233), (16392369; 8103), (18152379; 8973), (19912389; 9843).

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF55A68F.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.