Задание EGEINF5ABB91: Эффективная обработка данных и кластеры

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Эффективная обработка данных и кластеры.

Учебные темы: Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность; Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых
файлов.

 

По каналу связи передаётся последовательность целых неотрицательных чисел – показания прибора, полученные
с интервалом в 1 мин. в течение T мин. (T – целое число). Прибор измеряет количество атмосферных осадков, полученное регистратором за минуту, предшествующую моменту регистрации,
и передаёт это значение в условных единицах измерения.

Определите два таких переданных числа, чтобы между моментами их передачи прошло не менее K мин., а их сумма была максимально возможной. Укажите найденное суммарное количество осадков.

Входные данные

Даны два входных файла (файл A и файл B), каждый из которых
в первой строке содержит натуральное число K – количество минут, которое должно пройти между двумя передачами показаний, а во второй – количество переданных показаний N (1 ≤ N ≤ 10 000 000,
N > K). В каждой из следующих N строк находится одно целое неотрицательное число, не превышающее 100 000, обозначающее количество осадков за соответствующую минуту.

Запишите в ответе два числа: сначала значение искомой величины для файла А, затем – для файла B.

Типовой пример организации данных во входном файле

3

5

15

10

200

0

30

При таких исходных данных максимально возможное суммарное количество осадков равно 45 – это сумма осадков, выпавших на первой и пятой минутах.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

Предупреждение: для обработки файла B не следует использовать переборный алгоритм, вычисляющий сумму для всех возможных вариантов, поскольку написанная по такому алгоритму программа будет выполняться слишком долго.

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 5ABB91
НЕ РЕШЕНО Ответить

Решение задания EGEINF5ABB91

Ответ: 1608 7142285

Решение.

Обрабатываем два приложенных текстовых файла отдельно. В файле A содержится 1000 записей, в файле B — 4000000. Заголовок задаёт параметры и не является элементом последовательности. Порядок исходных записей сохраняем. Числа из иллюстративного примера не заменяют данные файлов.

В первой строке файла записано K, во второй — N. Расстояние между позициями равно разности их номеров. Для i < j требуется j − i ≥ K, то есть i ≤ j − K. Равенство K допустимо.

Фиксируем позицию j. Среди допустимых элементов слева поддерживаем максимум на позициях до j − K включительно: перед проверкой j добавляем элемент aⱼ₋ₖ. При фиксированном aⱼ сумма монотонно возрастает по остальным слагаемым. Независимый выбор нужного экстремума с каждой стороны даёт максимум для данного j.

Перебираем j от K до N − 1 в нумерации программы от нуля. Все допустимые варианты представлены, а границы исключают повторное использование позиции. Начальное значение best = None не ограничивает возможный знак суммы. Целые числа Python точно хранят и большие произведения.

Важное уточнение к исходным данным: в условии указана верхняя граница 100000, однако исходный файл B содержит значения до 3571143; выше указанной границы находятся 3888300 записей. Ни одну запись не отбрасываем и не обрезаем. Требуемые максимальная сумма и расстояние между позициями определены для всех значений файла; приведённый алгоритм не зависит от этой ошибочной верхней границы.

Распакуем архив и положим указанные в программе текстовые файлы рядом с ней. Программа печатает результат для A, затем для B:

from array import array

def solve(name):
    with open(name, encoding="utf-8-sig") as f:
        k = int(f.readline())
        n = int(f.readline())
        a = array("q", (int(f.readline()) for _ in range(n)))

    left = a[0]
    best = None
    for j in range(k, n):
        left = max(left, a[j - k])
        value = left + a[j]
        if best is None or value > best:
            best = value
    return best

print(solve('1_27_A.txt'), solve('1_27_B.txt'))

Время O(N), память O(N). Считывание и все арифметические действия выполняются над целыми числами; округление вычисленных ответов не требуется.

Проверка на исходных файлах. Номера элементов ниже отсчитываются от 1; полный алгоритм проверяет все допустимые варианты, а указанные позиции показывают достижение найденного результата.

ФайлВыбранные позицииЗначенияРезультат
A215, 616804, 8041608
B1752076, 32488363571143, 35711427142285

Файл A: (804) + (804) = 1608. Разности соседних выбранных номеров равны 401; каждая не меньше K = 20.

Файл B: (3571143) + (3571142) = 7142285. Разности соседних выбранных номеров равны 1496760; каждая не меньше K = 1000000.

Ответ: 1608 7142285.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF5ABB91.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.