Задание EGEINF3169CC: Эффективная обработка данных и кластеры

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Эффективная обработка данных и кластеры.

Учебные темы: Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность; Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых
файлов.

 

Пусть S – последовательность из N целых чисел, пронумерованных подряд начиная с 1. Обозначим Si, Sj, Sk три элемента последовательности S, где i < j < k.

Определите в последовательности S три таких числа Si, Sj, Sk, что Si > Sj, Sk > Sj и значение выражения (Si – Sj) + (Sk – Sj) максимально. В ответе укажите найденное максимальное значение выражения (Si – Sj) + (Sk – Sj). Гарантируется, что в последовательности есть три числа Si, Sj, Sk, удовлетворяющие условию задачи.

 

Входные данные

Дано два входных файла (файл A и файл B), каждый из которых в первой строке содержит число N (5 ≤ N ≤ 10 000 000) – количество целых чисел. Каждая из следующих N строк содержит одно целое число, значение которого по модулю не превышает 1000.

В ответе укажите два числа: сначала значение искомой величины для файла А, затем – для файла B.

 

Типовой пример организации данных во входном файле

9

6

9

7

5

8

6

10

–5

–6

При таких входных данных искомую максимальную сумму разностей образуют второй, четвёртый и седьмой элементы данной последовательности. Значение этой суммы разностей равно (9 – 5) + (10 – 5) = 9. Для седьмого, восьмого и девятого элементов последовательности искомая величина равна 14, но девятый элемент меньше восьмого, что не удовлетворяет условию задачи. Ответом является число 9.

 

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

Предупреждение: для обработки файла B не следует использовать переборный алгоритм, вычисляющий искомую величину для всех возможных вариантов, поскольку написанная по такому алгоритму программа будет выполняться слишком долго.

 

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.16 Динамическое программирование как метод решения задач с сохранением промежуточных результатов. Задачи, решаемые с помощью динамического программирования: вычисление рекурсивных функций, подсчёт количества вариантов, задачи оптимизации
Тип ответа:Краткий ответ
Номер: 3169CC
НЕ РЕШЕНО Ответить

Решение задания EGEINF3169CC

Ответ: 957 1292

Решение.

Обрабатываем два приложенных текстовых файла отдельно. В файле A содержится 315 записей, в файле B — 999990. Заголовок задаёт параметры и не является элементом последовательности. Порядок исходных записей сохраняем. Числа из иллюстративного примера не заменяют данные файлов.

Пусть i < j < k — выбранные позиции. Средний элемент должен быть строго меньше обоих крайних. Искомая величина равна (aᵢ − aⱼ) + (aₖ − aⱼ) = aᵢ + aₖ − 2aⱼ.

Положим vᵢ = −aᵢ: после смены знаков средний элемент должен быть строго больше крайних. В обоих случаях максимизируем 2vⱼ − vᵢ − vₖ. При фиксированном j левый и правый выбор независимы, поэтому выбираем минимум v слева и минимум v справа. Если один из этих минимумов не меньше vⱼ, подходящей тройки с данным средним элементом вообще нет.

Массив right[i] хранит минимум от позиции i до конца и строится справа налево. При просмотре j поддерживаем минимум строго левее j. Сравниваем оба минимума с vⱼ строгими неравенствами, затем обновляем общий максимум. Перебор всех внутренних j охватывает каждую допустимую тройку через её среднюю позицию; независимый выбор минимумов даёт лучший результат для этого j.

Распакуем архив и положим указанные в программе текстовые файлы рядом с ней. Программа печатает результат для A, затем для B:

from array import array

def solve(name):
    with open(name, encoding="utf-8-sig") as f:
        n = int(f.readline())
        a = array("q", (int(f.readline()) for _ in range(n)))

    sign = -1
    v = array("q", (sign * x for x in a))
    right = array("q", v)
    for i in range(n - 2, -1, -1):
        right[i] = min(right[i], right[i + 1])
    left = v[0]
    best = None
    for j in range(1, n - 1):
        left = min(left, v[j - 1])
        if left < v[j] and right[j + 1] < v[j]:
            value = 2 * v[j] - left - right[j + 1]
            if best is None or value > best:
                best = value
    return best

print(solve('319_27_A.txt'), solve('319_27_B.txt'))

Время O(N), память O(N). Считывание и все арифметические действия выполняются над целыми числами; округление вычисленных ответов не требуется.

Проверка на исходных файлах. Номера элементов ниже отсчитываются от 1; полный алгоритм проверяет все допустимые варианты, а указанные позиции показывают достижение найденного результата.

ФайлВыбранные позицииЗначенияРезультат
A1, 120, 31556, -301, 299957
B655, 9360, 13489323, -323, 3231292

Файл A: (56) + (299) − 2 · (-301) = 957. Строгие сравнения среднего элемента с крайними выполнены.

Файл B: (323) + (323) − 2 · (-323) = 1292. Строгие сравнения среднего элемента с крайними выполнены.

Ответ: 957 1292.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF3169CC.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.