Задание EGEINF519CA0: Эффективная обработка данных и кластеры

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Эффективная обработка данных и кластеры.

Учебные темы: Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность; Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых
файлов.

 

Пусть S – последовательность из N целых чисел, пронумерованных подряд начиная с 1. Обозначим S(L, R) подпоследовательность, состоящую из идущих подряд элементов, входящих в S, начиная с элемента с номером L и заканчивая элементом с номером R.

Требуется найти такие значения номеров элементов L, M, R, где
0 < L < M < R – 1 (т.е. между элементами с номерами M и R есть ещё как минимум один элемент), чтобы разность суммы элементов подпоследовательности S(M + 1, R) и суммы элементов подпоследовательности S(L, M) была максимальна.

В ответе укажите максимальное значение разности подобных сумм.

 

Входные данные

Дано два входных файла (файл A и файл B), каждый из которых в первой строке содержит число N (5 ≤ N ≤ 10 000 000) – количество целых чисел. Каждая из следующих N строк содержит одно целое число, значение которого по модулю не превышает 1000.

В ответе укажите два числа: сначала значение искомой величины для файла А, затем – для файла B.

 

Типовой пример организации данных во входном файле

7

20

4

–2

13

–1

2

–10

 

При таких входных данных L = 2, M = 3, R = 6. Искомая максимальная разность равна (13 + (–1) + 2) – (4 + (–2)) = 12. Подпоследовательность «–2 13 –1» разбить на две подпоследовательности требуемого вида невозможно.

Ответом является число 12.

 

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

Предупреждение: для обработки файла B не следует использовать переборный алгоритм, вычисляющий разность для всех возможных вариантов, поскольку написанная по такому алгоритму программа будет выполняться слишком долго.

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.16 Динамическое программирование как метод решения задач с сохранением промежуточных результатов. Задачи, решаемые с помощью динамического программирования: вычисление рекурсивных функций, подсчёт количества вариантов, задачи оптимизации
Тип ответа:Краткий ответ
Номер: 519CA0
НЕ РЕШЕНО Ответить

Решение задания EGEINF519CA0

Ответ: 120581 133560104

Решение.

Обрабатываем два приложенных текстовых файла отдельно. В файле A содержится 311 записей, в файле B — 999978. Заголовок задаёт параметры и не является элементом последовательности. Порядок исходных записей сохраняем. Числа из иллюстративного примера не заменяют данные файлов.

Максимизируем сумму правого блока минус сумму левого. Положим vᵢ = −aᵢ: нужная разность теперь равна сумме v в левом блоке минус сумме v в правом. Из L < M и M < R − 1 следует, что каждый блок содержит как минимум два элемента; блоки соседние.

Пусть P — префиксные суммы v и l = L − 1. Тогда разность равна (Pₘ − Pₗ) − (Pᵣ − Pₘ) = 2Pₘ − Pₗ − Pᵣ. При фиксированном M допустимы l ≤ M − 2 и R ≥ M + 2. Выбор левой и правой границы независим: берём минимальный Pₗ в левом диапазоне и минимальный Pᵣ в правом.

Заранее строим минимумы префиксных сумм справа. При движении M от 2 до N − 2 включительно обновляем минимум слева добавлением Pₘ₋₂ и вычисляем разность. Так проверены все допустимые середины и лучший выбор границ для каждой. Использование Pₘ₋₁ или Pₘ₊₁ допустило бы блок из одного элемента и решало бы другую задачу.

Распакуем архив и положим указанные в программе текстовые файлы рядом с ней. Программа печатает результат для A, затем для B:

from array import array

def solve(name):
    sign = -1
    prefix = array("q", [0])
    with open(name, encoding="utf-8-sig") as f:
        n = int(f.readline())
        for _ in range(n):
            prefix.append(prefix[-1] + sign * int(f.readline()))
    right = array("q", prefix)
    for i in range(n - 1, -1, -1):
        right[i] = min(right[i], right[i + 1])
    left = prefix[0]
    best = None
    for mid in range(2, n - 1):
        left = min(left, prefix[mid - 2])
        value = 2 * prefix[mid] - left - right[mid + 2]
        if best is None or value > best:
            best = value
    return best

print(solve('307_27_A.txt'), solve('307_27_B.txt'))

Время O(N), память O(N). Считывание и все арифметические действия выполняются над целыми числами; округление вычисленных ответов не требуется.

Проверка на исходных файлах. Номера элементов ниже отсчитываются от 1; полный алгоритм проверяет все допустимые варианты, а указанные позиции показывают достижение найденного результата.

ФайлLMRЛевая суммаПравая суммаРазность
A1156311-6098859593120581
B166664333325833315-6671735866842746133560104

В обеих строках проверены L < M < R − 1. Разность сумм взята в порядке, заданном условием; обе суммы дополнительно рассчитаны непосредственно по выбранным отрезкам.

Ответ: 120581 133560104.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF519CA0.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.