Задание EGEINF1D695E: Эффективная обработка данных и кластеры

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Эффективная обработка данных и кластеры.

Учебные темы: Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность; Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

 

Задание выполняется с использованием прилагаемых
к заданию файлов.

 

Дана последовательность из N натуральных чисел. Рассматриваются все её непрерывные подпоследовательности, такие что сумма элементов каждой из них кратна k = 61. Найдите среди них подпоследовательность с максимальной суммой, определите её длину. Если таких подпоследовательностей найдено несколько,
в ответе укажите количество элементов самой короткой из них.

Входные данные

Даны два входных файла (файл A и файл B), каждый из которых содержит в первой строке количество чисел N (1 ≤ N ≤ 10 000 000). Каждая из следующих N строк содержит одно натуральное число,
не превышающее 10 000.

Пример организации исходных данных во входном файле:

7

1

3

4

93

8

5

95

Для указанных входных данных при k = 50 искомая длина последовательности равна 2.

В ответе укажите два числа: значение длины искомой подпоследовательности сначала для файла А, затем для файла B.

 

Предупреждение: для обработки файла B не следует использовать переборный алгоритм для всех возможных вариантов, поскольку написанная по такому алгоритму программа будет выполняться слишком долго.

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 1D695E
НЕ РЕШЕНО Ответить

Решение задания EGEINF1D695E

Ответ: 104 276338

Решение.

Обрабатываем два приложенных текстовых файла отдельно. В файле A содержится 617 записей, в файле B — 1714614. Заголовок задаёт параметры и не является элементом последовательности. Порядок исходных записей сохраняем. Числа из иллюстративного примера не заменяют данные файлов.

Пусть P₀ = 0, Pᵣ — сумма первых r чисел. Сумма от l + 1 до r равна Pᵣ − Pₗ. Она делится на 61 тогда и только тогда, когда остатки Pᵣ и Pₗ при делении на 61 совпадают.

Все исходные числа положительны, поэтому префиксные суммы строго возрастают. Для фиксированного правого конца наибольшая сумма получается при самом раннем префиксе с нужным остатком. Храним только первую пару «сумма, позиция» для каждого остатка. Остаток ноль сначала соответствует пустому префиксу (0, 0); это позволяет учитывать отрезки с первого элемента.

При каждом новом правом конце сначала сравниваем сумму с текущим максимумом. Только при равных максимальных суммах выбираем меньшую длину r − l. Искомый ответ — длина выбранного отрезка, а не его сумма. Проверка выполняется до добавления нового остатка, поэтому пустой отрезок не рассматривается. Последующие префиксы того же остатка не заменяют первый: для любого будущего конца они дают строго меньшую сумму.

Распакуем архив и положим указанные в программе текстовые файлы рядом с ней. Программа печатает результат для A, затем для B:

from array import array

def solve(name):
    mod = 61
    first = {0: (0, 0)}
    prefix = 0
    best_sum = None
    best_length = None
    with open(name, encoding="utf-8-sig") as f:
        n = int(f.readline())
        for r in range(1, n + 1):
            prefix += int(f.readline())
            rem = prefix % mod
            if rem in first:
                base, l = first[rem]
                value = prefix - base
                length = r - l
                if (best_sum is None or value > best_sum
                        or value == best_sum and length < best_length):
                    best_sum = value
                    best_length = length
            else:
                first[rem] = (prefix, r)
    return best_length

print(solve('313_27_A.txt'), solve('313_27_B.txt'))

Время O(N), дополнительная память O(k), где k — делитель. Считывание и все арифметические действия выполняются над целыми числами; округление вычисленных ответов не требуется.

Проверка на исходных файлах. Номера элементов ниже отсчитываются от 1; полный алгоритм проверяет все допустимые варианты, а указанные позиции показывают достижение найденного результата.

ФайлНачалоКонецСуммаДлина
A4025051004548104
B10000021276339227544457276338

Для каждой строки длина равна конец − начало + 1. Указанные суммы делятся на 61; при сравнении всех максимальных сумм применено правило минимальной длины.

Ответ: 104 276338.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF1D695E.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.