Задание EGEINF475BA8: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите количество строк таблицы, для чисел которых выполнены оба условия:

– в строке есть одно число, которое повторяется в строке трижды, остальные четыре числа различны;

– повторяющееся число не является ни максимальным, ни минимальным числом строки.

В ответе запишите только число.

Скачать файл задания (ODS, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
4.2 Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц
4.4 Вероятностные модели. Методы Монте-Карло. Имитационное моделирование. Системы массового обслуживания
Тип ответа:Краткий ответ
Номер: 475BA8
НЕ РЕШЕНО Ответить

Решение задания EGEINF475BA8

Ответ: 36

Решение.
В приложенном файле 16000 строк по 7 натуральных чисел; первая строка уже содержит данные. Проверяем строки независимо и сохраняем их исходную нумерацию.
Составим частоты значений. Требуется ровно одно число, встречающееся три раза, и четыре других попарно различных числа, каждое по одному. Частоты должны быть ровно [1, 1, 1, 1, 3].
Пусть повторяющееся значение равно t. Список repeat содержит все три его вхождения, список single — только неповторяющиеся значения.
Повторяющееся значение не должно быть ни минимальным, ни максимальным в строке. Проверяем min < t < max. После проверки частот оба неравенства строгие и точно выражают это требование.
Для воспроизводимого подсчёта сохраним заполненный лист как текст с разделителями табуляции под именем data.txt в кодировке UTF-8. Заголовок добавлять не нужно. При экспорте должны сохраниться все 16000 строк и все 7 чисел каждой строки. Метод split() разбирает как табуляции, так и пробелы.
Следующая программа проверяет оба требования для каждой строки:

from collections import Counter

answer = 0
with open("data.txt", encoding="utf-8-sig") as f:
    for number, line in enumerate(f, 1):
        a = sorted(map(int, line.split()))
        c = Counter(a)
        single = [x for x in a if c[x] == 1]
        repeat = [x for x in a if c[x] > 1]
        ok = (sorted(c.values()) == [1, 1, 1, 1, 3] and a[0] < repeat[0] < a[-1])
        if ok:
            answer += 1
print(answer)

Counter хранит частоту каждого значения. Оператор and означает одновременное выполнение условий; если проверка частот не прошла, второе выражение не вычисляется.
Каждая строка учитывается не более одного раза. Полный проход даёт 36 подходящих строк.
Контроль нескольких найденных строк:

Номер строкиЗначения
62966, 71, 35, 35, 24, 68, 35
88337, 23, 23, 12, 16, 23, 66
143832, 32, 81, 22, 56, 87, 32
1367447, 49, 25, 39, 49, 49, 77
1581771, 50, 50, 50, 22, 44, 55

Например, строка 629: Частоты значений равны [1, 1, 1, 1, 3]; неповторяющиеся: [24, 66, 68, 71], повторяющиеся с учётом всех вхождений: [35, 35, 35]. 24 < 35 < 71.
Проверка выполнена также по исходному XLSX: независимый алгоритм подсчёта частот совпал по всем выбранным номерам строк.
Ответ: 36.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF475BA8.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.