Задание EGEINF38FB28: Пары и тройки в числовых данных

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Пары и тройки в числовых данных.

Учебные темы: Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

 

 

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых файлов.

В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых сумма остатков от деления обоих элементов на 11 равна минимальному элементу последовательности. В ответе запишите количество найденных пар, затем минимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

 

 

Скачать файл задания (TXT, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.6 Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования
Тип ответа:Краткий ответ
Номер: 38FB28
НЕ РЕШЕНО Ответить

Решение задания EGEINF38FB28

Ответ: 738 3451

Решение.

В файле 10000 чисел, каждое записано в отдельной строке. Первое число — элемент последовательности, а не её длина. Рассматриваем только соседние пары, сохраняя исходный порядок. Всего начальных позиций 10000 − 1 = 9999; соседние окна могут пересекаться.

Сначала находим минимальное число во всём файле: m = 8. Это общий порог для всех пар; его не нужно пересчитывать внутри цикла.

Для соседних x и y вычисляем остатки r₁ и r₂ при делении на 11. Условие отбора: r₁ + r₂ = m. Складываем именно два отдельных остатка; остаток от деления суммы x + y — другое выражение. Проверяем равенство, без округлений.

Для каждого подходящего окна увеличиваем счётчик на 1 и обновляем минимальную сумму. Перебор идёт по начальным позициям от 1 до 9999 включительно; ни одна допустимая соседняя пара не пропускается и не проверяется дважды.

Сохраним приложенный текстовый файл под именем data.txt рядом с программой. Программа на Python:

with open("data.txt", encoding="utf-8-sig") as f:
    a = [int(x) for x in f.read().split()]

m = min(a)
count = 0
best = None
for i in range(len(a) - 1):
    w = a[i:i + 2]
    s = sum(w)
    if sum(x % 11 for x in w) == m:
        count += 1
        if best is None or s < best:
            best = s

print(count, best)

Начальное best = None означает отсутствие найденного окна. Ноль не используется как искусственная начальная граница: реальные суммы могут иметь любой разрешённый условием знак. В данном файле подходящие окна существуют. Данные читаются за линейное время; основной цикл имеет постоянный размер окна, поэтому вся работа занимает O(n), память списка — O(n).

Проверка результата. Полный проход даёт 738 подходящих окон. Минимальная сумма равна 3451. Контрольные окна с позициями, отсчитываемыми от 1:

Начальная позицияЭлементыСумма
7345746; 61215106961
8741811; 660848419
33522885; 5663451

Окно с начальной позицией 3352 достигает найденного экстремума. Остатки: 3, 5; общий минимум m = 8. Таблица иллюстрирует результат; полноту количества и экстремума обеспечивает проверка всех начальных позиций, а не только этих примеров.

Ответ: 738 3451.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF38FB28.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.