Задание EGEINF2FDD04: Делители, маски и отбор чисел

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Делители, маски и отбор чисел.

Учебные темы: Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена».

Впишите правильный ответ.

Пусть M – сумма минимального и максимального натуральных делителей целого числа, не считая единицы и самого числа. Если таких делителей у числа нет, то считаем значение M равным нулю.

Напишите программу, которая перебирает целые числа, бо́льшие 700 000, в порядке возрастания и ищет среди них такие, для которых M оканчивается на 4. В ответе запишите в первом столбце таблицы первые пять найденных чисел в порядке возрастания, а во втором столбце – соответствующие им значения M.

 

Например, для числа 20 М = 2 + 10 = 12.

Количество строк в таблице для ответа избыточно.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 2FDD04
НЕ РЕШЕНО Ответить

Решение задания EGEINF2FDD04

Ответ: (700004; 350004), (700009; 41194), (700023; 233344), (700024; 350014), (700044; 350024)

Решение.
Требуются первые пять чисел, строго больших 700000. Начинаем с 700001 и рассматриваем целые n подряд в порядке возрастания.
Для каждого целого d от 2 до ⌊√n⌋ проверяем остаток при делении n на d. При нулевом остатке добавляем d и парный делитель nd. Множество устраняет повторение в случае d² = n.
Это полный список делителей без 1 и n: в любой паре сомножителей хотя бы один не больше √n. Поэтому каждую пару находим, в том числе пары с большим вторым делителем.
Если список пуст, M = 0. Иначе берём его минимум p и максимум q, получаем M = p + q. Дополнительная проверка: q = np, поскольку при увеличении положительного делителя парный сомножитель уменьшается. Для квадрата простого числа минимум и максимум равны и складываются дважды.
Требуемое условие: остаток от деления M на 10 равен 4.
n = 700004: минимальный делитель 2, максимальный 350002; 2 · 350002 = 700004.
M = 2 + 350002 = 350004; 350004 = 10 · 35000 + 4.
n = 700009: минимальный делитель 17, максимальный 41177; 17 · 41177 = 700009.
M = 17 + 41177 = 41194; 41194 = 10 · 4119 + 4.
n = 700023: минимальный делитель 3, максимальный 233341; 3 · 233341 = 700023.
M = 3 + 233341 = 233344; 233344 = 10 · 23334 + 4.
n = 700024: минимальный делитель 2, максимальный 350012; 2 · 350012 = 700024.
M = 2 + 350012 = 350014; 350014 = 10 · 35001 + 4.
n = 700044: минимальный делитель 2, максимальный 350022; 2 · 350022 = 700044.
M = 2 + 350022 = 350024; 350024 = 10 · 35002 + 4.
Полный последовательный перебор от 700001 до 700044 включительно проверяет 44 чисел. Условие выполняется ровно для пяти перечисленных n. Все меньшие допустимые кандидаты проверены, поэтому это именно первые пять чисел.
Проверка результата.
Воспроизводимая программа Python:

from math import isqrt

def proper_divisors(n):
    result = set()
    for d in range(2, isqrt(n) + 1):
        q, r = divmod(n, d)
        if r == 0:
            result.update((d, q))
    return sorted(result)

n = 700000
found = 0
while found != 5:
    n += 1
    d = proper_divisors(n)
    value = d[0] + d[-1] if d else 0
    ok = value % 10 == 4
    if ok:
        print(n, value)
        found += 1

Результат: в каждой строке слева n, справа M.
700004 — 350004
700009 — 41194
700023 — 233344
700024 — 350014
700044 — 350024
Ответ: (700004; 350004), (700009; 41194), (700023; 233344), (700024; 350014), (700044; 350024).

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF2FDD04.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.