Задание EGEINF115302: Делители, маски и отбор чисел

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Делители, маски и отбор чисел.

Учебные темы: Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена».

Впишите правильный ответ.

Напишите программу, которая перебирает целые числа, бо́льшие 700 000, в порядке возрастания и ищет среди них такие, у которых есть натуральный делитель, оканчивающийся на цифру 9
и не равный ни самому числу, ни числу 9. Вывести первые
пять найденных чисел и для каждого наименьший им делитель, оканчивающийся на цифру 9, не равный ни самому числу, ни числу 9.

Формат вывода: для каждого из пяти таких найденных чисел
в отдельной строке сначала выводится само число, затем – значение наименьшего делителя, оканчивающегося на цифру 9, не равного ни самому числу, ни числу 9.

Строки выводятся в порядке возрастания найденных чисел.

Количество строк в таблице для ответа избыточно.

 

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 115302
НЕ РЕШЕНО Ответить

Решение задания EGEINF115302

Ответ: (700002; 29), (700003; 18919), (700004; 139), (700005; 69), (700011; 39)

Решение.
Требуются первые пять чисел, строго больших 700000. Начинаем с 700001 и рассматриваем целые n подряд в порядке возрастания.
Для каждого целого d от 2 до ⌊√n⌋ проверяем остаток при делении n на d. При нулевом остатке добавляем d и парный делитель nd. Множество устраняет повторение в случае d² = n.
Это полный список делителей без 1 и n: в любой паре сомножителей хотя бы один не больше √n. Поэтому каждую пару находим, в том числе пары с большим вторым делителем.
Из полного списка оставляем делители с остатком 9 при делении на 10 и исключаем само число 9. Число n уже исключено при построении списка. Если подходящих делителей несколько, нужен наименьший, а не первый найденный парный сомножитель.
n = 700002: все разрешённые делители — 29, 149, 2349, 12069, 38889.
Минимум равен 29; 29 · 24138 = 700002; 29 = 10 · 2 + 9.
29 отличается от 9 и от 700002.
n = 700003: все разрешённые делители — 18919.
Минимум равен 18919; 18919 · 37 = 700003; 18919 = 10 · 1891 + 9.
18919 отличается от 9 и от 700003.
n = 700004: все разрешённые делители — 139, 1259.
Минимум равен 139; 139 · 5036 = 700004; 139 = 10 · 13 + 9.
139 отличается от 9 и от 700004.
n = 700005: все разрешённые делители — 69, 2029.
Минимум равен 69; 69 · 10145 = 700005; 69 = 10 · 6 + 9.
69 отличается от 9 и от 700005.
n = 700011: все разрешённые делители — 39, 279, 579, 1209, 2509, 17949, 77779.
Минимум равен 39; 39 · 17949 = 700011; 39 = 10 · 3 + 9.
39 отличается от 9 и от 700011.
Полный последовательный перебор от 700001 до 700011 включительно проверяет 11 чисел. Условие выполняется ровно для пяти перечисленных n. Все меньшие допустимые кандидаты проверены, поэтому это именно первые пять чисел.
Проверка результата.
Воспроизводимая программа Python:

from math import isqrt

def proper_divisors(n):
    result = set()
    for d in range(2, isqrt(n) + 1):
        q, r = divmod(n, d)
        if r == 0:
            result.update((d, q))
    return sorted(result)

n = 700000
found = 0
while found != 5:
    n += 1
    d = proper_divisors(n)
    allowed = [x for x in d if x % 10 == 9 and x != 9]
    value = allowed[0] if allowed else 0
    ok = bool(allowed)
    if ok:
        print(n, value)
        found += 1

Результат: в каждой строке слева n, справа делитель.
700002 — 29
700003 — 18919
700004 — 139
700005 — 69
700011 — 39
Ответ: (700002; 29), (700003; 18919), (700004; 139), (700005; 69), (700011; 39).

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF115302.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.