Задание EGEINF0C76DB: Пары и тройки в числовых данных

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Пары и тройки в числовых данных.

Учебные темы: Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых
файлов.

 

В файле содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения
от 1 до 100 000 включительно. Определите количество троек элементов последовательности, в которых только одно из чисел является четырёхзначным, а сумма элементов тройки не меньше максимального элемента последовательности, оканчивающегося
на 15. В ответе запишите количество найденных троек чисел, затем максимальную из сумм элементов таких троек. В данной задаче под тройкой подразумевается три идущих подряд элемента последовательности.

 

Скачать файл задания (TXT, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.6 Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования
Тип ответа:Краткий ответ
Номер: 0C76DB
НЕ РЕШЕНО Ответить

Решение задания EGEINF0C76DB

Ответ: 299 196183

Решение.

В файле 6646 чисел, каждое записано в отдельной строке. Первое число — элемент последовательности, а не её длина. Рассматриваем только соседние тройки, сохраняя исходный порядок. Всего начальных позиций 6646 − 2 = 6644; соседние окна могут пересекаться.

Сначала среди всех чисел, запись которых оканчивается на 15, находим наибольшее. Условие окончания: остаток от деления |x| на 100 равен 15. Получаем m = 96615. Максимум выбирается из самих чисел x, со знаком; модуль используется только для проверки цифр.

Число содержит 4 цифры в записи модуля тогда и только тогда, когда 1000 ≤ |x| < 10000. Знак минуса не считается цифрой. В каждой тройке подсчитываем такие элементы; требуется ровно 1. Затем для суммы s проверяем s ≥ m.

Неравенство нестрогое, поэтому равенство порогу подходит.

Для каждого подходящего окна увеличиваем счётчик на 1 и обновляем максимальную сумму. Перебор идёт по начальным позициям от 1 до 6644 включительно; ни одна допустимая соседняя тройка не пропускается и не проверяется дважды.

Сохраним приложенный текстовый файл под именем data.txt рядом с программой. Программа на Python:

with open("data.txt", encoding="utf-8-sig") as f:
    a = [int(x) for x in f.read().split()]

m = max(x for x in a if abs(x) % 100 == 15)
count = 0
best = None
for i in range(len(a) - 2):
    w = a[i:i + 3]
    s = sum(w)
    if sum(1000 <= abs(x) < 10000 for x in w) == 1 and s >= m:
        count += 1
        if best is None or s > best:
            best = s

print(count, best)

Начальное best = None означает отсутствие найденного окна. Ноль не используется как искусственная начальная граница: реальные суммы могут иметь любой разрешённый условием знак. В данном файле подходящие окна существуют. Данные читаются за линейное время; основной цикл имеет постоянный размер окна, поэтому вся работа занимает O(n), память списка — O(n).

Проверка результата. Полный проход даёт 299 подходящих окон. Максимальная сумма равна 196183. Контрольные окна с позициями, отсчитываемыми от 1:

Начальная позицияЭлементыСумма
9531; 92495; 9344101870
9692495; 9344; 94344196183

Окно с начальной позицией 96 достигает найденного экстремума. Чисел нужной разрядности 1; 196183 ≥ 96615. Таблица иллюстрирует результат; полноту количества и экстремума обеспечивает проверка всех начальных позиций, а не только этих примеров.

Ответ: 299 196183.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF0C76DB.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.