Задание OGEINFE4F7CA: Написание программы

ФИПИ · ОГЭ · все форматы ответа · 1585 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Написание программы.

Учебные темы: Табличные величины (массивы). Одномерные массивы. Составление и отладка программ, реализующих типовые алгоритмы обработки одномерных числовых массивов, на одном из языков программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык): заполнение числового массива случайными числами, в соответствии с формулой или путём ввода чисел, нахождение суммы элементов массива, линейный поиск заданного значения в массиве, подсчёт элементов массива, удовлетворяющих заданному условию, нахождение минимального (максимального) элемента массива. Сортировка массива. Обработка потока данных: вычисление количества, суммы, среднего арифметического, минимального и максимального значения элементов последовательности, удовлетворяющих заданному условию.

Дайте развернутый ответ.

Напишите программу, которая в последовательности натуральных десятичных чисел определяет сумму элементов, запись которых в системе счисления с основанием 7 оканчивается цифрой 6. Если среди входных данных таких элементов нет, программа должна вывести «NO».

Программа получает на вход натуральные десятичные числа,
не превышающие 30 000, каждое в отдельной строке. Количество введённых чисел неизвестно, их последовательность заканчивается числом 0 (0 – признак окончания ввода, в последовательность не входит).

Программа должна вывести одно число – сумму десятичных чисел (элементов последовательности), запись которых в 7-ричной системе счисления оканчивается цифрой 6, или «NO», если среди входных данных таких элементов нет.

 

Пример работы программы

Входные данные

Выходные данные

20

13

9

28

12

0

33

 

 


 

i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Язык программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык). Система программирования: редактор текста программ, транслятор, отладчик. Переменная: тип, имя, значение. Целые, вещественные и символьные переменные. Оператор присваивания. Арифметические выражения и порядок их вычисления. Операции с целыми числами: целочисленное деление, остаток от деления. Ветвления. Составные условия (запись логических выражений на изучаемом языке программирования). Нахождение минимума и максимума из двух, трёх и четырёх чисел. Решение квадратного уравнения, имеющего вещественные корни. Цикл с условием. Алгоритм Евклида для нахождения наибольшего общего делителя двух натуральных чисел. Разбиение записи натурального числа в позиционной системе с основанием, меньшим или равным 10, на отдельные цифры. Цикл с переменной. Алгоритмы проверки делимости одного целого числа на другое, проверки натурального числа на простоту
Тип ответа:Развернутый ответ
Номер: E4F7CA
НЕ РЕШЕНО Изменить статус

Решение задания OGEINFE4F7CA

Ответ: Программа приведена в шаге 3

1. Разберём формат ввода.
Ввод содержит сами числа, а не их количество. Считываем очередное число и прежде всего проверяем, равно ли оно нулю. При нуле завершаем обработку: этот признак окончания не входит в последовательность и не должен влиять на сумму, количество, среднее или экстремум.

2. Выберем алгоритм.
Последняя цифра в системе с основанием 7 равна остатку от деления модуля числа на 7. Требуемый остаток — 6. Используем равенство |x| = 7 · q + r, где 0 ≤ r ≤ 6. Поэтому весь перевод записи числа не нужен.
Сумма total начинается с нуля. При каждом подходящем числе прибавляем само число x, сохраняя его знак. Неподходящие значения ничего не добавляют.
Если подходящих элементов не оказалось, выводим строго NO. Даже когда найденная сумма или среднее равны нулю, при наличии элементов нужно вывести число, а не NO.

3. Программа на Python 3.

import sys

data = iter(map(int, sys.stdin.buffer.read().split()))
count = 0
total = 0
best = None
for x in data:
    if x == 0:
        break
    if abs(x) % 7 == 6:
        count += 1
        total += x
if count == 0:
    print("NO")
else:
    print(total)

4. Проверка и обоснование.
Пример 1. Входные числа: 20 13 9 28 12 0.
Подходящие элементы: 20, 13. Их количество — 2. Сумма: 20 + 13 = 33.
Вывод: 33.
После каждой обработанной записи накопленные значения точно описывают уже просмотренную часть данных. На очередном шаге неподходящий элемент ничего не меняет, а подходящий учитывается один раз. После последней записи получаем результат для всей последовательности. Каждая запись обрабатывается один раз, поэтому время работы линейно по количеству записей. Алгоритму достаточно нескольких накопителей; приведённый способ чтения сохраняет входной текст, поэтому общая память программы линейна по размеру ввода.

Ответ: Программа приведена в шаге 3.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании OGEINFE4F7CA.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.