Задание OGEINFC3AEB5: Написание программы

ФИПИ · ОГЭ · все форматы ответа · 1585 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Написание программы.

Учебные темы: Язык программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык). Система программирования: редактор текста программ, транслятор, отладчик. Переменная: тип, имя, значение. Целые, вещественные и символьные переменные. Оператор присваивания. Арифметические выражения и порядок их вычисления. Операции с целыми числами: целочисленное деление, остаток от деления. Ветвления. Составные условия (запись логических выражений на изучаемом языке программирования). Нахождение минимума и максимума из двух, трёх и четырёх чисел. Решение квадратного уравнения, имеющего вещественные корни. Цикл с условием. Алгоритм Евклида для нахождения наибольшего общего делителя двух натуральных чисел. Разбиение записи натурального числа в позиционной системе с основанием, меньшим или равным 10, на отдельные цифры. Цикл с переменной. Алгоритмы проверки делимости одного целого числа на другое, проверки натурального числа на простоту.

Дайте развернутый ответ.

Напишите программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество чётных натуральных чисел на отрезке [a, b] (включая концы отрезка).

Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1 ≤ a ≤ b ≤ 30000. Проверять входные данные на корректность не нужно.

Программа должна вывести одно число: количество чётных чисел на отрезке [a, b].

Пример работы программы:

Входные данные

Выходные данные

10

20

6

 

 


 

i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Язык программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык). Система программирования: редактор текста программ, транслятор, отладчик. Переменная: тип, имя, значение. Целые, вещественные и символьные переменные. Оператор присваивания. Арифметические выражения и порядок их вычисления. Операции с целыми числами: целочисленное деление, остаток от деления. Ветвления. Составные условия (запись логических выражений на изучаемом языке программирования). Нахождение минимума и максимума из двух, трёх и четырёх чисел. Решение квадратного уравнения, имеющего вещественные корни. Цикл с условием. Алгоритм Евклида для нахождения наибольшего общего делителя двух натуральных чисел. Разбиение записи натурального числа в позиционной системе с основанием, меньшим или равным 10, на отдельные цифры. Цикл с переменной. Алгоритмы проверки делимости одного целого числа на другое, проверки натурального числа на простоту
Тип ответа:Развернутый ответ
Номер: C3AEB5
НЕ РЕШЕНО Изменить статус

Решение задания OGEINFC3AEB5

Ответ: Программа приведена в шаге 3

1. Разберём формат ввода.
На вход подаются только границы a и b. По условию они натуральные и удовлетворяют 1 ≤ a ≤ b ≤ 30000. Никакого отдельного количества элементов здесь нет. Нужно учесть оба конца отрезка.

2. Выберем алгоритм.
Перебираем все целые x от a до b включительно. Для каждого проверяем остаток от деления на 2 и увеличиваем счётчик при нулевом остатке. В Python правая граница range не включается, поэтому используем b + 1. Если a = b, всё равно рассматриваем единственное число; ответ тогда равен 1 для чётного числа и 0 для нечётного.

3. Программа на Python 3.

import sys

data = iter(map(int, sys.stdin.buffer.read().split()))
a = next(data)
b = next(data)
count = 0
for x in range(a, b + 1):
    if x % 2 == 0:
        count += 1
print(count)

4. Проверка и обоснование.
Пример 1. Входные числа: 10 20.

Вывод: 6.
После рассмотрения очередного числа счётчик равен количеству чётных целых от a до этого числа включительно. Перебор заканчивается на b, поэтому учитывается весь требуемый отрезок. Число итераций равно b − a + 1 и не превышает 30000.

Ответ: Программа приведена в шаге 3.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании OGEINFC3AEB5.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.