Задание OGEINF41E9E1: Написание программы

ФИПИ · ОГЭ · все форматы ответа · 1585 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Написание программы.

Учебные темы: Табличные величины (массивы). Одномерные массивы. Составление и отладка программ, реализующих типовые алгоритмы обработки одномерных числовых массивов, на одном из языков программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык): заполнение числового массива случайными числами, в соответствии с формулой или путём ввода чисел, нахождение суммы элементов массива, линейный поиск заданного значения в массиве, подсчёт элементов массива, удовлетворяющих заданному условию, нахождение минимального (максимального) элемента массива. Сортировка массива. Обработка потока данных: вычисление количества, суммы, среднего арифметического, минимального и максимального значения элементов последовательности, удовлетворяющих заданному условию.

Дайте развернутый ответ.

Напишите программу для решения следующей задачи.

Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов.

Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ.

 

Пример работы программы:

Входные данные

Выходные данные

4

15

12

0

17

17

YES

 


 

i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Язык программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык). Система программирования: редактор текста программ, транслятор, отладчик. Переменная: тип, имя, значение. Целые, вещественные и символьные переменные. Оператор присваивания. Арифметические выражения и порядок их вычисления. Операции с целыми числами: целочисленное деление, остаток от деления. Ветвления. Составные условия (запись логических выражений на изучаемом языке программирования). Нахождение минимума и максимума из двух, трёх и четырёх чисел. Решение квадратного уравнения, имеющего вещественные корни. Цикл с условием. Алгоритм Евклида для нахождения наибольшего общего делителя двух натуральных чисел. Разбиение записи натурального числа в позиционной системе с основанием, меньшим или равным 10, на отдельные цифры. Цикл с переменной. Алгоритмы проверки делимости одного целого числа на другое, проверки натурального числа на простоту
Тип ответа:Развернутый ответ
Номер: 41E9E1
НЕ РЕШЕНО Изменить статус

Решение задания OGEINF41E9E1

Ответ: Программа приведена в шаге 3

1. Разберём формат ввода.
Сначала читаем N — количество элементов или участников, затем обрабатываем ровно N записей. Первое число N не участвует в вычислении результата. Для каждой записи читаем одно число. Данные могут быть разделены переносами строк или пробелами: программа одинаково обрабатывает оба варианта.

2. Выберем алгоритм.
Текущий максимум — наибольшее число правильных ответов среди уже прочитанных результатов. Отдельно запоминаем, встретился ли результат 0. Ноль здесь является результатом участника и обрабатывается вместе с остальными значениями. Печатаем максимум, затем YES при наличии нулевого результата и NO в противном случае.

3. Программа на Python 3.

import sys

data = iter(map(int, sys.stdin.buffer.read().split()))
count = 0
total = 0
best = None
flag = False
n = next(data)
for _ in range(n):
    x = next(data)
    if best is None or x > best:
        best = x
    if x == 0:
        flag = True
print(best)
print("YES" if flag else "NO")

4. Проверка и обоснование.
Пример 1. Входные числа: 4 15 12 0 17.

Вывод: 17 YES.
На каждом шаге обновляются только показатели для уже прочитанных записей. После обработки всех записей они относятся ко всему набору данных. Проверки границ используют ровно строгие или нестрогие сравнения из условия. Каждая запись обрабатывается один раз, поэтому время работы линейно по количеству записей. Алгоритму достаточно нескольких накопителей; приведённый способ чтения сохраняет входной текст, поэтому общая память программы линейна по размеру ввода.

Ответ: Программа приведена в шаге 3.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании OGEINF41E9E1.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.