Задание OGEINF249C36: Анализ программы с ветвлением

ФИПИ · ОГЭ · все форматы ответа · 1585 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Анализ программы с ветвлением.

Учебные темы: Язык программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык). Система программирования: редактор текста программ, транслятор, отладчик. Переменная: тип, имя, значение. Целые, вещественные и символьные переменные. Оператор присваивания. Арифметические выражения и порядок их вычисления. Операции с целыми числами: целочисленное деление, остаток от деления. Ветвления. Составные условия (запись логических выражений на изучаемом языке программирования). Нахождение минимума и максимума из двух, трёх и четырёх чисел. Решение квадратного уравнения, имеющего вещественные корни. Цикл с условием. Алгоритм Евклида для нахождения наибольшего общего делителя двух натуральных чисел. Разбиение записи натурального числа в позиционной системе с основанием, меньшим или равным 10, на отдельные цифры. Цикл с переменной. Алгоритмы проверки делимости одного целого числа на другое, проверки натурального числа на простоту.

Впишите правильный ответ.

Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический язык

Паскаль

алг

нач

цел s, t, A

ввод s

ввод t

ввод A

если s > А или t > 11

то вывод "YES"

иначе вывод "NO"

все

кон

var s, t, A: integer;

begin

 readln(s);

 readln(t);

 readln(A);

 if (s > А) or (t > 11)

  then writeln('YES')

  else writeln('NO')

end.

Бейсик

Python

DIM s, t, A AS INTEGER

INPUT s

INPUT t

INPUT A

IF s > А OR t > 11 THEN

  PRINT "YES"

ELSE

  PRINT "NO"

ENDIF

s = int(input())

t = int(input())

A = int(input())

if (s > А) or (t > 11):

    print("YES")

else:

    print("NO")

C++

#include <iostream>

using namespace std;

 

int main(){

   int s, t, A;

   cin >> s;

   cin >> t;

   cin >> A;

   if (s > А || t > 11)

     cout << "YES" << endl;

   else

     cout << "NO" << endl;

   return 0;

 }

 

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).

Укажите количество целых значений параметра А, при которых для указанных входных данных программа напечатает «NO» шесть раз.



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Язык программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык). Система программирования: редактор текста программ, транслятор, отладчик. Переменная: тип, имя, значение. Целые, вещественные и символьные переменные. Оператор присваивания. Арифметические выражения и порядок их вычисления. Операции с целыми числами: целочисленное деление, остаток от деления. Ветвления. Составные условия (запись логических выражений на изучаемом языке программирования). Нахождение минимума и максимума из двух, трёх и четырёх чисел. Решение квадратного уравнения, имеющего вещественные корни. Цикл с условием. Алгоритм Евклида для нахождения наибольшего общего делителя двух натуральных чисел. Разбиение записи натурального числа в позиционной системе с основанием, меньшим или равным 10, на отдельные цифры. Цикл с переменной. Алгоритмы проверки делимости одного целого числа на другое, проверки натурального числа на простоту
Тип ответа:Краткий ответ
Номер: 249C36
НЕ РЕШЕНО Ответить

Решение задания OGEINF249C36

Ответ: 2

1. Разберём условие программы.
Сообщение YES выводится, когда условие истинно, а NO — когда оно ложно. Запишем проверяемое выражение словами:
(s больше A ИЛИ t больше 11).
Операция И требует истинности обеих частей, ИЛИ — хотя бы одной; НЕ меняет истину на ложь и наоборот. Сначала выполняются сравнения и действия в скобках, затем соответствующие логические операции. Равенство граничному числу проверяем особенно внимательно.

2. Определим зависимость от A.
NO получается только тогда, когда обе части ИЛИ ложны: t ≤ 11 И s ≤ A. Условие t ≤ 11 выполняется в запусках 1, 2, 4, 5, 6, 7, 8, 9. Остальные всегда дают YES и от A не зависят.
Выпишем значения s из подходящих запусков по возрастанию, сохраняя повторения:
−9, 2, 2, 7, 7, 9, 11, 12.
Число сообщений NO равно количеству чисел этого списка, не превосходящих A. Повторы относятся к разным запускам, поэтому каждый учитывается отдельно. Число YES равно 9 минус число NO.
Требуемое количество сообщений NO — 6; соответствующее количество NO — 6. A должно быть не меньше числа на месте 6, равного 9, и меньше числа на месте 7, равного 11. Для целого A это даёт 9 ≤ A ≤ 10.

3. Выберем ответ из найденного диапазона.
Нужно количество целых значений, включая обе границы. Оно равно 10 − (9) + 1 = 2. Диапазон учитывает все целые значения A, в том числе отрицательные; произвольного ограничения поиска нет.

4. Проверка.
Подставим A = 9 в исходную программу и проверим каждый запуск:
Запуск 1: (−9; 11) — вывод NO.
Запуск 2: (2; 7) — вывод NO.
Запуск 3: (5; 12) — вывод YES.
Запуск 4: (2; −2) — вывод NO.
Запуск 5: (7; −9) — вывод NO.
Запуск 6: (12; 6) — вывод YES.
Запуск 7: (9; −1) — вывод NO.
Запуск 8: (7; 11) — вывод NO.
Запуск 9: (11; −5) — вывод YES.
Получено 3 сообщения YES и 6 сообщений NO; требуемых NO — 6. При соседнем A = 8 сообщений NO уже 5. При соседнем A = 11 сообщений NO уже 7. При увеличении A число NO не уменьшается, а число YES не увеличивается, поэтому за границами найденного диапазона нужное количество не появится снова. Ответом служит количество целых A, а выбранное для проверки значение не заменяет этот ответ.

Ответ: 2.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании OGEINF249C36.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.