Задание OGEINF10198C: Написание программы

ФИПИ · ОГЭ · все форматы ответа · 1585 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Написание программы.

Учебные темы: Табличные величины (массивы). Одномерные массивы. Составление и отладка программ, реализующих типовые алгоритмы обработки одномерных числовых массивов, на одном из языков программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык): заполнение числового массива случайными числами, в соответствии с формулой или путём ввода чисел, нахождение суммы элементов массива, линейный поиск заданного значения в массиве, подсчёт элементов массива, удовлетворяющих заданному условию, нахождение минимального (максимального) элемента массива. Сортировка массива. Обработка потока данных: вычисление количества, суммы, среднего арифметического, минимального и максимального значения элементов последовательности, удовлетворяющих заданному условию.

Дайте развернутый ответ.

Напишите программу подсчёта количества элементов последовательности натуральных чисел, запись которых в шестнадцатеричной системе счисления трёхзначна и оканчивается на цифру 3. В ответе запишите количество искомых элементов.

На вход программе сначала подаётся количество элементов последовательности N (1 ≤ N ≤ 1000), затем каждый элемент последовательности в отдельной строке.

Программа должна напечатать только одно число – количество искомых элементов последовательности.

 

Пример работы программы

Входные данные

Выходные данные

5

163

275

883

947

4115

3


 

i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Язык программирования (Python, C++, Паскаль, Java, C#, Школьный Алгоритмический Язык). Система программирования: редактор текста программ, транслятор, отладчик. Переменная: тип, имя, значение. Целые, вещественные и символьные переменные. Оператор присваивания. Арифметические выражения и порядок их вычисления. Операции с целыми числами: целочисленное деление, остаток от деления. Ветвления. Составные условия (запись логических выражений на изучаемом языке программирования). Нахождение минимума и максимума из двух, трёх и четырёх чисел. Решение квадратного уравнения, имеющего вещественные корни. Цикл с условием. Алгоритм Евклида для нахождения наибольшего общего делителя двух натуральных чисел. Разбиение записи натурального числа в позиционной системе с основанием, меньшим или равным 10, на отдельные цифры. Цикл с переменной. Алгоритмы проверки делимости одного целого числа на другое, проверки натурального числа на простоту
Тип ответа:Развернутый ответ
Номер: 10198C
НЕ РЕШЕНО Изменить статус

Решение задания OGEINF10198C

Ответ: Программа приведена в шаге 3

1. Разберём формат ввода.
Сначала читаем N — количество элементов или участников, затем обрабатываем ровно N записей. Первое число N не участвует в вычислении результата. Для каждой записи читаем одно число. Данные могут быть разделены переносами строк или пробелами: программа одинаково обрабатывает оба варианта.

2. Выберем алгоритм.
Количество цифр в записи по основанию 16 должно быть равно 3. Это равносильно границам 16² ≤ x ≤ 16³ − 1, то есть 256 ≤ x ≤ 4095. Левый конец включён, следующее значение 4096 уже имеет больше цифр.
Последняя цифра в системе с основанием 16 равна остатку от деления модуля числа на 16. Требуемый остаток — 3. Используем равенство |x| = 16 · q + r, где 0 ≤ r ≤ 15. Поэтому весь перевод записи числа не нужен.
Все перечисленные требования должны выполняться одновременно, поэтому соединяем проверки оператором and.
Счётчик count начинается с нуля. При каждом подходящем числе увеличиваем его на один. Одинаковые значения на разных местах последовательности считаются отдельными элементами.
Если подходящих чисел нет, счётчик или сумма остаются равны нулю; программа выводит 0.

3. Программа на Python 3.

import sys

data = iter(map(int, sys.stdin.buffer.read().split()))
count = 0
total = 0
best = None
n = next(data)
for _ in range(n):
    x = next(data)
    if 256 <= x < 4096 and abs(x) % 16 == 3:
        count += 1
print(count)

4. Проверка и обоснование.
Пример 1. Входные числа: 5 163 275 883 947 4115.
Подходящие элементы: 275, 883, 947. Их количество — 3.
Вывод: 3.
После каждой обработанной записи накопленные значения точно описывают уже просмотренную часть данных. На очередном шаге неподходящий элемент ничего не меняет, а подходящий учитывается один раз. После последней записи получаем результат для всей последовательности. Каждая запись обрабатывается один раз, поэтому время работы линейно по количеству записей. Алгоритму достаточно нескольких накопителей; приведённый способ чтения сохраняет входной текст, поэтому общая память программы линейна по размеру ввода.

Ответ: Программа приведена в шаге 3.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании OGEINF10198C.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.