Задание EGEINFEAAB94: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите сумму чисел в строке с наименьшим номером, для чисел которой выполнены оба условия:

– в строке все числа различны;

– удвоенная сумма минимального и максимального чисел строки больше утроенной суммы трёх её оставшихся чисел.

В ответе запишите только число.

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
4.2 Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц
Тип ответа:Краткий ответ
Номер: EAAB94
НЕ РЕШЕНО Ответить

Решение задания EGEINFEAAB94

Ответ: 480

Решение.
В файле 16000 строк по 5 натуральных чисел. Первая строка содержит данные, поэтому её номер равен 1; дополнительную строку заголовков при нумерации не добавляем. Проверяем оба условия для каждой исходной строки и сохраняем её настоящий номер.

Сначала требуем пять различных значений: количество элементов множества строки должно быть равно 5. После сортировки обозначим значения a < b < c < d < e. Первое и последнее — минимум и максимум, остальные три — b, c, d.

Второе условие записываем без изменения строгости: 2(a + e) > 3(b + c + d). Равенство не подходит. Перебираем строки сверху вниз; первая прошедшая обе проверки имеет наименьший номер. В ответ требуется сумма её чисел, а не номер строки.

Проверить отбор можно программой Python. Для неё копируем только исходные числовые ячейки листа в текстовый файл data.txt: одна строка таблицы на строку файла, числа разделены пробелами или табуляциями. Строки не сортируем и не добавляем заголовок.

from collections import Counter

selected = []
with open("data.txt", encoding="utf-8-sig") as f:
    rows = [list(map(int, line.split())) for line in f if line.strip()]
for number, a in enumerate(rows, 1):
    assert len(a) == 5
    ok = len(set(a)) == 5
    if ok:
        b = sorted(a)
        ok = 2 * (b[0] + b[4]) > 3 * sum(b[1:4])
    if ok:
        selected.append((number, a))
print(sum(selected[0][1]))

Полный отбор дал 194 подходящих строк. Первая из них имеет номер 59. Её значения: 255, 85, 34, 68, 38.

Все пять значений различны. Проверяем неравенство: 2 · (34 + 255) = 578, а 3 · (38 + 68 + 85) = 573. Левая часть больше правой. Сумма выбранной строки: 255 + 85 + 34 + 68 + 38 = 480.

Проверка. Независимый отбор через сортировку значений и длины серий совпал с подсчётом частот по всем номерам выбранных строк. Данные ODS и XLSX совпали по каждой числовой ячейке.

Ответ: 480.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINFEAAB94.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.