Задание EGEINFE8867C: Эффективная обработка данных и кластеры

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Эффективная обработка данных и кластеры.

Учебные темы: Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность; Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых
файлов.

 

По каналу связи передаётся последовательность целых чисел – показания прибора. В течение N мин. (N – натуральное число) прибор ежеминутно регистрирует значение напряжения (в условных единицах) в электрической сети и передаёт его на сервер.

Определите три таких переданных числа, чтобы между моментами передачи любых двух из них прошло не менее K мин., а сумма этих трёх чисел была максимально возможной. Запишите в ответе найденную сумму.

Входные данные

Даны два входных файла (файл A и файл B), каждый из которых
в первой строке содержит натуральное число K – минимальное количество минут, которое должно пройти между моментами передачи показаний, а во второй – количество переданных показаний N (1 ≤ N ≤ 10 000 000, N > K). В каждой из следующих
N строк находится одно целое число, по модулю не превышающее 10 000 000, которое обозначает значение напряжения в соответствующую минуту.

Запишите в ответе два числа: сначала значение искомой величины для файла А, затем – для файла B.

 

Типовой пример организации данных во входном файле

2

6

150

–150

20

–200

–300

0

При таких исходных данных искомая величина равна 170 – это сумма значений, зафиксированных на первой, третьей и шестой минутах измерений.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

Предупреждение: для обработки файла B не следует использовать переборный алгоритм, вычисляющий сумму для всех возможных вариантов, поскольку написанная по такому алгоритму программа будет выполняться слишком долго.

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: E8867C
НЕ РЕШЕНО Ответить

Решение задания EGEINFE8867C

Ответ: 187918 17227

Решение.

Обрабатываем два приложенных текстовых файла отдельно. В файле A содержится 775 записей, в файле B — 991698. Заголовок задаёт параметры и не является элементом последовательности. Порядок исходных записей сохраняем. Числа из иллюстративного примера не заменяют данные файлов.

В первой строке файла записано K, во второй — N. Расстояние между позициями равно разности их номеров. Для i < j < k нужны j − i ≥ K и k − j ≥ K. Тогда k − i ≥ 2K выполняется автоматически, но одной проверки крайнего расстояния недостаточно.

Фиксируем позицию j. Среди допустимых элементов слева поддерживаем максимум на позициях до j − K включительно: перед проверкой j добавляем элемент aⱼ₋ₖ. Справа нужен максимум на позициях от j + K до конца; заранее строим массив таких экстремумов обратным проходом. При фиксированном aⱼ сумма монотонно возрастает по остальным слагаемым. Независимый выбор нужного экстремума с каждой стороны даёт максимум для данного j.

Перебираем j от K до N − K − 1 в нумерации программы от нуля. Все допустимые варианты представлены, а границы исключают повторное использование позиции. Начальное значение best = None не ограничивает возможный знак суммы. Целые числа Python точно хранят и большие произведения.

Распакуем архив и положим указанные в программе текстовые файлы рядом с ней. Программа печатает результат для A, затем для B:

from array import array

def solve(name):
    with open(name, encoding="utf-8-sig") as f:
        k = int(f.readline())
        n = int(f.readline())
        a = array("q", (int(f.readline()) for _ in range(n)))

    right = array("q", a)
    for i in range(n - 2, -1, -1):
        right[i] = max(right[i], right[i + 1])

    left = a[0]
    best = None
    for j in range(k, n - k):
        left = max(left, a[j - k])
        value = left + a[j] + right[j + k]
        if best is None or value > best:
            best = value
    return best

print(solve('313_27_A.txt'), solve('313_27_B.txt'))

Время O(N), память O(N). Считывание и все арифметические действия выполняются над целыми числами; округление вычисленных ответов не требуется.

Проверка на исходных файлах. Номера элементов ниже отсчитываются от 1; полный алгоритм проверяет все допустимые варианты, а указанные позиции показывают достижение найденного результата.

ФайлВыбранные позицииЗначенияРезультат
A232, 389, 55655465, 77283, 55170187918
B7260, 330566, 5180093678, 5575, 797417227

Файл A: (55465) + (77283) + (55170) = 187918. Разности соседних выбранных номеров равны 157, 167; каждая не меньше K = 155.

Файл B: (3678) + (5575) + (7974) = 17227. Разности соседних выбранных номеров равны 323306, 187443; каждая не меньше K = 165283.

Ответ: 187918 17227.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINFE8867C.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.