Задание EGEINFE7EB1F: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– наибольшее из четырёх чисел меньше суммы трёх других;

– среди четырёх чисел есть только одна пара равных чисел.

В ответе запишите только число.

Скачать файл задания (ODS, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
4.2 Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц
4.4 Вероятностные модели. Методы Монте-Карло. Имитационное моделирование. Системы массового обслуживания
Тип ответа:Краткий ответ
Номер: E7EB1F
НЕ РЕШЕНО Ответить

Решение задания EGEINFE7EB1F

Ответ: 147

Решение.
В приложенном файле 3200 строк по 4 натуральных чисел; первая строка уже содержит данные. Проверяем строки независимо и сохраняем их исходную нумерацию.
Для четырёх чисел после сортировки a ≤ b ≤ c ≤ d первое условие имеет вид d < a + b + c. Равенство не подходит. Проверяем только одно выбранное вхождение максимума; при совпадении значений остальные входят в сумму.
Во втором условии ровно одна пара равных, а оставшиеся два значения различны между собой и не равны парному. Поэтому отсортированный список частот должен быть ровно [1, 1, 2]. Две пары и тройное повторение не подходят.
Для воспроизводимого подсчёта сохраним заполненный лист как текст с разделителями табуляции под именем data.txt в кодировке UTF-8. Заголовок добавлять не нужно. При экспорте должны сохраниться все 3200 строк и все 4 чисел каждой строки. Метод split() разбирает как табуляции, так и пробелы.
Следующая программа проверяет оба требования для каждой строки:

from collections import Counter

answer = 0
with open("data.txt", encoding="utf-8-sig") as f:
    for number, line in enumerate(f, 1):
        a = sorted(map(int, line.split()))
        c = Counter(a)
        single = [x for x in a if c[x] == 1]
        repeat = [x for x in a if c[x] > 1]
        ok = (a[-1] < sum(a[:-1]) and sorted(c.values()) == [1, 1, 2])
        if ok:
            answer += 1
print(answer)

Counter хранит частоту каждого значения. Оператор and означает одновременное выполнение условий; если проверка частот не прошла, второе выражение не вычисляется.
Каждая строка учитывается не более одного раза. Полный проход даёт 147 подходящих строк.
Контроль нескольких найденных строк:

Номер строкиЗначения
6426, 58, 47, 26
876, 9, 46, 46
15780, 48, 58, 48
315461, 61, 43, 29
315727, 93, 46, 46

Например, строка 64: Максимум 58 меньше суммы остальных 99. Частоты различных значений: [1, 1, 2].
Проверка выполнена также по исходному XLSX: независимый алгоритм подсчёта частот совпал по всем выбранным номерам строк.
Ответ: 147.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINFE7EB1F.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.