Задание EGEINFC629FB: Поиск ошибок в программе

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Поиск ошибок в программе.

Учебные темы: Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования.

Дайте развернутый ответ.

На обработку поступает натуральное число, не превышающее 109. Нужно написать программу, которая выводит на экран минимальную цифру числа, делящуюся на 3. Если в числе нет цифр, делящихся на 3, на экран требуется вывести «NO». Программист написал программу неправильно. Ниже эта программа для Вашего удобства приведена на пяти языках программирования.

Напоминание: 0 делится на любое натуральное число.

Бейсик

Python

DIM N, DIGIT, MINDIGIT AS LONG

INPUT N

MINDIGIT = 9

WHILE N > 0

  DIGIT = N MOD 10

  IF DIGIT MOD 3 = 0  THEN

    IF DIGIT < MINDIGIT THEN

      DIGIT = MINDIGIT

    END IF

  END IF

  N = N \ 10

WEND

IF MINDIGIT <= 9 THEN

  PRINT MINDIGIT

ELSE

  PRINT "NO"

END IF

N = int(input())

minDigit = 9

while N > 0:

  digit = N % 10

  if digit % 3 == 0:

    if digit < minDigit:

      digit = minDigit

  N = N // 10

if minDigit <= 9:

  print(minDigit)

else:

  print("NO")

Алгоритмический язык

Паскаль

алг

нач

  цел N, digit, minDigit

  ввод N

  minDigit := 9

  нц пока N > 0

    digit := mod(N,10)

    если mod(digit, 3) = 0 то

      если digit < minDigit то

        digit := minDigit

      все

    все

    N := div(N,10)

  кц

  если minDigit <= 9 то

    вывод minDigit

  иначе

    вывод "NO"

  все

кон

var N,digit,minDigit: longint;

begin

  readln(N);

  minDigit := 9;

  while N > 0 do

  begin

    digit := N mod 10;

    if digit mod 3 = 0 then

      if digit < minDigit then

        digit := minDigit;

    N := N div 10;

  end;

  if minDigit <= 9 then

    writeln(minDigit)

  else

    writeln('NO')

end.


 

С++

#include <iostream>

using namespace std;

 

int main()

{

  int N, digit, minDigit;

  cin >> N;

  minDigit = 9;

  while (N > 0)

  {

    digit = N % 10;

    if (digit % 3 == 0)

      if (digit < minDigit)

        digit = minDigit;

    N = N / 10;

  }

  if (minDigit <= 9)

    cout << minDigit << endl;

  else

    cout << "NO" << endl;

  return 0;

}

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе числа 143.

2. Приведите пример такого трёхзначного числа, при вводе которого программа выдаёт верный ответ.

3. Найдите все ошибки в этой программе (их может быть одна или несколько). Известно, что каждая ошибка затрагивает только одну строку
и может быть исправлена без изменения других строк. Для каждой ошибки:

1) выпишите строку, в которой сделана ошибка;

2) укажите, как исправить ошибку, т.е. приведите правильный вариант строки.

Достаточно указать ошибки и способ их исправления для одного языка программирования.

Обратите внимание на то, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. Исправление ошибки должно затрагивать только строку, в которой находится ошибка.


 

i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.6 Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования
Тип ответа:Развернутый ответ
Номер: C629FB
НЕ РЕШЕНО Изменить статус

Решение задания EGEINFC629FB

Ответ: 1) 9; 2) 199; 3) minDigit = 10; minDigit = digit

На обработку поступает натуральное число, не превышающее 10⁹. Нужно написать программу, которая выводит на экран минимальную цифру числа, делящуюся на 3. Если в числе нет цифр, делящихся на 3, на экран требуется вывести «NO».

1. Выполнение исходной ошибочной программы.
Ввод: 143.
Шаг 1: N = 143, извлекается цифра 3; minDigit = 9; после удаления последней цифры N = 14. Ошибочное присваивание изменяет digit на 9, но искомый экстремум не обновляет.
Шаг 2: N = 14, извлекается цифра 4; minDigit = 9; после удаления последней цифры N = 1.
Шаг 3: N = 1, извлекается цифра 1; minDigit = 9; после удаления последней цифры N = 0.
Вывод программы: 9.
Этот вывод относится именно к исходному коду. Требуемый по условию результат для тех же данных: 3.

2. Пример, на котором исходная программа случайно даёт верный ответ.
Возьмём 199.
Шаг 1: N = 199, извлекается цифра 9; minDigit = 9; после удаления последней цифры N = 19.
Шаг 2: N = 19, извлекается цифра 9; minDigit = 9; после удаления последней цифры N = 1.
Шаг 3: N = 1, извлекается цифра 1; minDigit = 9; после удаления последней цифры N = 0.
Вывод исходной программы: 9.
Подходящие цифры: 9, 9. По условию получается 9, что совпадает с фактическим выводом.

3. Исправление ровно двух строк: Python.
Все остальные строки и отступы сохраняются.

Ошибка 1. Строка в исходной программе:

minDigit = 9

Правильная строка:

minDigit = 10

Значение 10 больше любой десятичной цифры и служит признаком отсутствия результата. Последняя цифра может не подходить, а значение 9 само является допустимой цифрой; их нельзя использовать как надёжный признак отсутствия минимума.

Ошибка 2. Строка в исходной программе:

      digit = minDigit

Правильная строка:

      minDigit = digit

Найденную подходящую цифру нужно сохранять в переменной экстремума. Обратное присваивание меняет временную digit, а накопленный результат оставляет прежним.

Проверка исправленной программы.
После обработки любого количества последних цифр накопленная переменная хранит минимум подходящих значений этой части.
Вначале обработанных значений нет: используется начальная граница 10. При неподходящем значении экстремум не меняется. При подходящем значение сравнивается с сохранённым: меньшее заменяет минимум. Поэтому утверждение сохраняется на каждом шаге.
После каждого шага последняя цифра удаляется целочисленным делением на 10. Положительное N уменьшается до 0, поэтому будут рассмотрены все цифры ровно по одному разу; при N ≤ 10⁹ требуется не более десяти шагов.
Если подходящих цифр не было, сохраняется начальный признак отсутствия результата; иначе сохранена допустимая цифра от 0 до 9. Заключительное ветвление различает эти два случая.
Для исходного ввода 143 исправленная программа выводит 3.
Необходимость исправления 1: если оставить только эту ошибку, при вводе 1 получится 9 вместо «NO».
Необходимость исправления 2: если оставить только эту ошибку, при вводе 3 получится «NO» вместо 3.

Ответ: 1) 9; 2) 199; 3) minDigit = 10; minDigit = digit.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINFC629FB.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.