Задание EGEINFC383CB: Редактор и машина Тьюринга

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Редактор и машина Тьюринга.

Учебные темы: Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат; Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно.

Впишите правильный ответ.

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды,
в обеих командах v и w обозначают цепочки цифр.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды

заменить (v, w)

не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

 

 

Цикл

ПОКА  условие 

последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

ЕСЛИ  условие

ТО команда1

ИНАЧЕ команда2

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

Дана программа для Редактора:

НАЧАЛО

ПОКА нашлось (25) ИЛИ нашлось (355) ИЛИ нашлось (555)

    ЕСЛИ нашлось (25)

      ТО заменить (25, 5)

    КОНЕЦ ЕСЛИ

    ЕСЛИ нашлось (355)

       ТО заменить (355, 52)

    КОНЕЦ ЕСЛИ

    ЕСЛИ нашлось (555)

       ТО заменить (555, 3)

    КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

 

На вход приведённой выше программе поступает строка, начинающаяся с цифры «2», а затем содержащая n цифр «5»
(n > 3).

Определите наименьшее значение n, при котором в строке, получившейся в результате выполнения программы, количество цифр «3» равно 2.



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.1 Формализация понятия алгоритма. Машина Тьюринга как универсальная модель вычислений
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
Тип ответа:Краткий ответ
Номер: C383CB
НЕ РЕШЕНО Ответить

Решение задания EGEINFC383CB

Ответ: 18

Решение.
Начальное слово состоит из цифры 2 и n цифр 5. Начинаем с n = 4, поскольку n — целое и строго больше 3.
На каждом проходе условия ЕСЛИ проверяются по текущей строке сверху вниз. Следующая проверка учитывает изменения предыдущей команды. В конструкции с ИНАЧЕ выполняется только одна ветвь. Каждая замена затрагивает только первое слева вхождение.
Каждая выполненная замена уменьшает длину строки. За один проход цикла выполняется хотя бы одна замена, поэтому обработка любого выбранного n завершится.
Для доказательства минимальности достаточно последовательно проверить n от 4 до 18 включительно и остановиться на первом подходящем результате. Воспроизводимый расчёт на Python:

for n in range(4, 19):
    s = '2' + '5' * n
    while (
        '25' in s
        or '355' in s
        or '555' in s
    ):
        if '25' in s:
            s = s.replace('25', '5', 1)
        if '355' in s:
            s = s.replace('355', '52', 1)
        if '555' in s:
            s = s.replace('555', '3', 1)
    if s.count('3') == 2:
        print(n)
        break

Проверены все целые значения от 4 до 18, всего 15, без пропусков.
При n от 4 до 17 количество цифр 3 принимает значения 0, 1; 2 среди них нет.
Контрольные результаты около первого подходящего значения:
n = 15: «32»; количество цифр 3 равно 1.
n = 16: «35»; количество цифр 3 равно 1.
n = 17: «52»; количество цифр 3 равно 0.
n = 18: «323»; количество цифр 3 равно 2.
Проверка случая n = 18 по выполненным заменам:
25→5: число замен — 3.
555→3: число замен — 5.
355→52: число замен — 3.
По окончании цикла (число проходов — 5) получаем «323». Ни одна из цепочек 25, 355, 555 больше не встречается.
Сумма цифр этого слова: 2 · 1 + 3 · 2 = 8.
Подходящее значение существует, а все меньшие допустимые значения исключены. Поэтому наименьшее n = 18.
Ответ: 18.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINFC383CB.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.