Задание EGEINFACDF4D: Обработка текстового файла

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Обработка текстового файла.

Учебные темы: Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Текстовый файл состоит из символов T, U, V, W, X, Y и Z.

Определите в прилагаемом файле максимальное количество идущих подряд символов (длину непрерывной подпоследовательности), среди которых символ T встречается ровно 100 раз.

Для выполнения этого задания следует написать программу.

Скачать файл задания (TXT, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
2.13 Графы. Основные понятия. Виды графов. Описание графов с помощью матриц смежности, весовых матриц, списков смежности. Решение алгоритмических задач, связанных с анализом графов (построение оптимального пути между вершинами графа, определение количества различных путей между вершинами ориентированного ациклического графа)
2.14 Деревья. Бинарное дерево. Деревья поиска. Способы обхода дерева. Представление арифметических выражений в виде дерева. Использование графов и деревьев при описании объектов и процессов окружающего мира
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.10 Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве
3.11 Двумерные массивы (матрицы). Алгоритмы обработки двумерных массивов: заполнение двумерного числового массива по заданным правилам, поиск элемента в двумерном массиве, вычисление максимума (минимума) и суммы элементов двумерного массива, перестановка строк и столбцов двумерного массива
3.12 Словари (ассоциативные массивы, отображения). Хэш-таблицы. Построение алфавитно-частотного словаря для заданного текста
3.13 Стеки. Анализ правильности скобочного выражения. Вычисление арифметического выражения, записанного в постфиксной форме. Очереди. Использование очереди для временного хранения данных
3.14 Алгоритмы на графах. Построение минимального остовного дерева взвешенного связного неориентированного графа. Количество различных путей между вершинами ориентированного ациклического графа. Алгоритм Дейкстры
3.15 Деревья. Реализация дерева с помощью ссылочных структур. Двоичные (бинарные) деревья. Построение дерева для заданного арифметического выражения. Рекурсивные алгоритмы обхода дерева. Использование стека и очереди для обхода дерева
Тип ответа:Краткий ответ
Номер: ACDF4D
НЕ РЕШЕНО Ответить

Решение задания EGEINFACDF4D

Ответ: 133

Решение.
Прочитаем строку из 24_2024.txt и удалим перевод строки в конце файла. Требуется максимальная длина непрерывного фрагмента с ровно 100 буквами T.
Будем двигать правую границу по одному символу. Левая граница left задаёт начало текущего фрагмента, переменная countt — количество T внутри него. Если после добавления символа букв T стало больше 100, сдвигаем left вправо, уменьшая счётчик при удалении каждой T, пока он снова не станет равен 100.
После этого left — самый ранний допустимый левый конец для текущей правой границы: все более ранние начала содержали бы лишнюю T. Если букв T ровно 100, длина текущего фрагмента равна right − left + 1; сравниваем её с максимумом. Фрагменты с меньшим числом T не засчитываем.
Программа на Python 3:

Перед запуском сохраните скачанный файл под именем 24_2024.txt рядом с программой.

with open('24_2024.txt') as source:
    text = source.read().strip()
left = 0
count_t = 0
best = 0
for right, symbol in enumerate(text):
    if symbol == 'T':
        count_t += 1
    while count_t > 100:
        if text[left] == 'T':
            count_t -= 1
        left += 1
    if count_t == 100:
        best = max(best, right - left + 1)
print(best)

В файле 10000000 символов, из них 9000842 буквы T. Результат программы — 133.
Проверка: один максимальный фрагмент занимает позиции с 4423153 по 4423285 включительно, считая с единицы. Его длина 4423285 − 4423153 + 1 = 133, количество T в нём ровно 100.
Независимый способ использует позиции всех T. Добавим условные позиции перед началом и после конца строки. Для каждой группы из 100 последовательных T берём весь промежуток между предшествующей и следующей T, не включая эти две внешние буквы. Это самый длинный фрагмент для данной группы. Максимум всех таких длин тоже равен 133. Условные крайние позиции позволяют учесть начало и конец файла.
Обе границы программы движутся только вправо, каждая не более L раз. Поэтому время O(L); кроме исходной строки используется постоянное количество памяти.
Ответ: 133.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINFACDF4D.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.