Задание EGEINF9F14BB: Делители, маски и отбор чисел

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Делители, маски и отбор чисел.

Учебные темы: Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена».

Впишите правильный ответ.

Назовём маской числа последовательность цифр, в которой также могут встречаться следующие символы:

–    символ «?» означает ровно одну произвольную цифру;

–    символ «*» означает любую последовательность цифр произвольной длины; в том числе «*» может задавать
и пустую последовательность.

Например, маске 123*4?5 соответствуют числа 123405 и 12300405.

Среди натуральных чисел, не превышающих 108, найдите все числа, соответствующие маске 123*67, делящиеся на 133 без остатка.

В ответе запишите в первом столбце таблицы все найденные числа
в порядке возрастания, а во втором столбце – соответствующие им результаты деления этих чисел на 133.

Количество строк в таблице для ответа избыточно.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 9F14BB
НЕ РЕШЕНО Ответить

Решение задания EGEINF9F14BB

Ответ: (1236767; 9299), (12302367; 92499), (12315667; 92599), (12328967; 92699), (12342267; 92799), (12355567; 92899), (12368867; 92999), (12382167; 93099), (12395467; 93199)

Решение.
Ищем все натуральные n, удовлетворяющие маске 123*67, ограничению n ≤ 10⁸ и делимости на 133.
Каждый знак «?» заменяется ровно одной десятичной цифрой. Звёздочка допускает пустую строку и строки с нулями в начале: эти нули находятся внутри записи числа и должны сохраняться.
Без звёздочки в маске 5 позиций, из них 0 обозначены знаком «?». Граница 10⁸ отдельно проверяется по маске и ей не соответствует. Все остальные допустимые числа содержат не более 8 цифр.
Поэтому длина замены «*» принимает все целые значения от 0 до 3. При длине k имеется 10⁰ · 10ᵏ подстановок.
Общее число подстановок: 1 + 10 + 100 + 1000 = 1111.
Первый символ маски — фиксированная ненулевая цифра. Подстановки дают натуральные числа без ведущего нуля; различные наборы замен дают разные записи. Перебор длин и всех цифр охватывает каждое допустимое число.
Для каждого кандидата вычисляем частное и остаток при делении на 133. Оставляем ровно те числа, у которых остаток равен нулю, затем упорядочиваем их по числовому значению.
Найденные числа и проверка каждой строки:
n = 1236767: «*» = «67».
133 · 9299 = 1236767; остаток 0.
n = 12302367: «*» = «023».
133 · 92499 = 12302367; остаток 0.
n = 12315667: «*» = «156».
133 · 92599 = 12315667; остаток 0.
n = 12328967: «*» = «289».
133 · 92699 = 12328967; остаток 0.
n = 12342267: «*» = «422».
133 · 92799 = 12342267; остаток 0.
n = 12355567: «*» = «555».
133 · 92899 = 12355567; остаток 0.
n = 12368867: «*» = «688».
133 · 92999 = 12368867; остаток 0.
n = 12382167: «*» = «821».
133 · 93099 = 12382167; остаток 0.
n = 12395467: «*» = «954».
133 · 93199 = 12395467; остаток 0.
Проверены все 1111 подстановок и отдельно верхняя граница; найдено 9 подходящих чисел. Других замен маски в допустимом диапазоне нет.
Проверка результата.
Воспроизводимая программа Python:

from itertools import product
from fnmatch import fnmatchcase

mask = '123*67'
limit = 10 ** 8
divisor = 133
fixed = len(mask.replace('*', ''))
lengths = range(8 - fixed + 1) if '*' in mask else [0]
numbers = set()
for length in lengths:
    pattern = mask.replace('*', '?' * length)
    for digits in product('0123456789', repeat=pattern.count('?')):
        it = iter(digits)
        text = ''.join(next(it) if c == '?' else c for c in pattern)
        numbers.add(int(text))
if fnmatchcase(str(limit), mask):
    numbers.add(limit)
for n in sorted(numbers):
    quotient, remainder = divmod(n, divisor)
    if remainder == 0:
        print(n, quotient)

Результат: в каждой строке слева n, справа частное.
1236767 — 9299
12302367 — 92499
12315667 — 92599
12328967 — 92699
12342267 — 92799
12355567 — 92899
12368867 — 92999
12382167 — 93099
12395467 — 93199
Ответ: (1236767; 9299), (12302367; 92499), (12315667; 92599), (12328967; 92699), (12342267; 92799), (12355567; 92899), (12368867; 92999), (12382167; 93099), (12395467; 93199).

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF9F14BB.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.