Задание EGEINF9EF0FE: Электронные таблицы и формулы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Электронные таблицы и формулы.

Учебные темы: Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– в строке все числа различны;

– утроенное произведение минимального и максимального чисел строки не больше, чем удвоенное произведение трёх её оставшихся чисел.

В ответе запишите только число.

Скачать файл задания (ODS, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
4.2 Анализ данных с помощью электронных таблиц. Вычисление суммы, среднего арифметического, наибольшего (наименьшего) значения диапазона. Вычисление коэффициента корреляции двух рядов данных. Построение столбчатых, линейчатых и круговых диаграмм. Построение графиков функций. Подбор линии тренда, решение задач прогнозирования. Решение задач оптимизации с помощью электронных таблиц
4.4 Вероятностные модели. Методы Монте-Карло. Имитационное моделирование. Системы массового обслуживания
Тип ответа:Краткий ответ
Номер: 9EF0FE
НЕ РЕШЕНО Ответить

Решение задания EGEINF9EF0FE

Ответ: 9829

Решение.
В приложенном файле 16000 строк по 5 натуральных чисел; первая строка уже содержит данные. Проверяем строки независимо и сохраняем их исходную нумерацию.
Отсортируем числа: a ≤ b ≤ c ≤ d ≤ e. Сначала проверим, что все пять различны: число ключей в таблице частот равно 5.
Затем проверим неравенство 3ae ≤ 2bcd. Формулировка «не меньше» или «не больше» включает равенство; используем соответствующий нестрогий знак. Оба условия должны выполниться одновременно.
Для воспроизводимого подсчёта сохраним заполненный лист как текст с разделителями табуляции под именем data.txt в кодировке UTF-8. Заголовок добавлять не нужно. При экспорте должны сохраниться все 16000 строк и все 5 чисел каждой строки. Метод split() разбирает как табуляции, так и пробелы.
Следующая программа проверяет оба требования для каждой строки:

from collections import Counter

answer = 0
with open("data.txt", encoding="utf-8-sig") as f:
    for number, line in enumerate(f, 1):
        a = sorted(map(int, line.split()))
        c = Counter(a)
        single = [x for x in a if c[x] == 1]
        repeat = [x for x in a if c[x] > 1]
        ok = (len(c) == 5 and 3 * a[0] * a[-1] <= 2 * a[1] * a[2] * a[3])
        if ok:
            answer += 1
print(answer)

Counter хранит частоту каждого значения. Оператор and означает одновременное выполнение условий; если проверка частот не прошла, второе выражение не вычисляется.
Каждая строка учитывается не более одного раза. Полный проход даёт 9829 подходящих строк.
Контроль нескольких найденных строк:

Номер строкиЗначения
296, 192, 82, 84, 144
4166, 83, 100, 95, 69
569, 138, 63, 192, 128
1599950, 100, 70, 78, 24
16000105, 70, 118, 128, 94

Например, строка 2: Все пять чисел различны. Левая часть неравенства равна 47232, правая — 2322432; нужный знак выполнен.
Проверка выполнена также по исходному XLSX: независимый алгоритм подсчёта частот совпал по всем выбранным номерам строк.
Ответ: 9829.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF9EF0FE.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.