Задание EGEINF89926C: Выполнение и анализ программы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Выполнение и анализ программы.

Учебные темы: Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат.

Впишите правильный ответ.

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: S и P. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 8, а потом 4.

С++

Python

#include <iostream>
using namespace std;

int main()
{ 

  int x, P, S, N;
  cin >> x;
  P = 1;

  S = 0;
  N = 0;
  while (x > 0) {
    N = N + 1;

    S = S + (x % 3)
    P = P * (x % 3)
    x = x / 3;
  }

  S = S + N;

  P = P + N;
  cout << S << endl << P << endl;
  return 0;
}

x = int(input())
P = 1
S = 0

N = 0
while x > 0:
  N = N + 1

  S = S + (x % 3)

  P = P * (x % 3)
  x = x // 3
S = S + N

P = P + N

print(S)
print(P)

Алгоритмический язык

Паскаль

алг
нач
  цел x, P, S, N
 
ввод x
  P := 1
  S := 0

  N := 0
  нц пока x > 0
   
N := N + 1

    S := S + mod(x, 3)

    P := P * mod(x, 3)
    x := div(x, 3)
 
кц

  S := S + N

  P := P + N
  вывод S, нс, P
кон

var x, P, S, N: integer;
begin
  readln(x);
  P := 1;
  S := 0;

  N := 0;
  while x > 0 do
  begin
    N := N + 1;

    S := S + (x mod 3);

    P := P * (x mod 3);
    x := x div 3
  end;

  S := S + N;

  P := P + N;
  writeln(S);
  writeln(P)
end.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.1 Формализация понятия алгоритма. Машина Тьюринга как универсальная модель вычислений
Тип ответа:Краткий ответ
Номер: 89926C
НЕ РЕШЕНО Ответить

Решение задания EGEINF89926C

Ответ: 72

Цикл выделяет цифры записи X в системе с основанием 3. Он считает их количество N, сумму S и произведение P. После цикла к сумме и произведению дополнительно прибавляется N.
Поэтому нужны сумма цифр 8 − N и произведение цифр 4 − N. Цифры неотрицательны, значит произведение неотрицательно и 1 ≤ N ≤ 4. Это даёт конечный полный разбор длины.
N = 1: требуются сумма 7 и произведение 3. Среди 1 цифр от 0 до 2 с ненулевой первой такой пары суммы и произведения нет.
N = 2: требуются сумма 6 и произведение 2. Среди 2 цифр от 0 до 2 с ненулевой первой такой пары суммы и произведения нет.
N = 3: требуются сумма 5 и произведение 1. Среди 3 цифр от 0 до 2 с ненулевой первой такой пары суммы и произведения нет.
N = 4: требуются сумма 4 и произведение 0. Допустимые записи: 1012, 1021, 1102, 1120, 1201, 1210, 2002, 2011, 2020, 2101, 2110, 2200.
Список получен перебором всех цифр каждой допустимой длины: ведущая от 1 до 2, остальные от 0 до 2. Каждая запись проверяется по двум равенствам; более длинная запись невозможна из оценки N ≤ 4.
Выбираем наибольшее число: 2200 (основание 3). В десятичной системе 2 · 3³ + 2 · 3² + 0 · 3¹ + 0 · 3⁰ = 72.
Проверка: сумма цифр 4 и N = 4 дают 8; произведение 0 и N дают 4.
Ответ: 72.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF89926C.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.