Задание EGEINF896732: Обработка текстового файла

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Обработка текстового файла.

Учебные темы: Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно.

Впишите правильный ответ.

Скачать 24.txt

 

 

Рисунок из условия ФИПИ

 Задание выполняется с использованием прилагаемых к заданию файлов.

 

Текстовый файл состоит не более чем из 1 200 000 символов X, Y, и Z. 

Определите максимальное количество идущих подряд символов, среди которых нет подстроки XZZY.

Для выполнения этого задания следует написать программу.



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
2.13 Графы. Основные понятия. Виды графов. Описание графов с помощью матриц смежности, весовых матриц, списков смежности. Решение алгоритмических задач, связанных с анализом графов (построение оптимального пути между вершинами графа, определение количества различных путей между вершинами ориентированного ациклического графа)
2.14 Деревья. Бинарное дерево. Деревья поиска. Способы обхода дерева. Представление арифметических выражений в виде дерева. Использование графов и деревьев при описании объектов и процессов окружающего мира
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.10 Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве
3.11 Двумерные массивы (матрицы). Алгоритмы обработки двумерных массивов: заполнение двумерного числового массива по заданным правилам, поиск элемента в двумерном массиве, вычисление максимума (минимума) и суммы элементов двумерного массива, перестановка строк и столбцов двумерного массива
3.12 Словари (ассоциативные массивы, отображения). Хэш-таблицы. Построение алфавитно-частотного словаря для заданного текста
3.13 Стеки. Анализ правильности скобочного выражения. Вычисление арифметического выражения, записанного в постфиксной форме. Очереди. Использование очереди для временного хранения данных
3.14 Алгоритмы на графах. Построение минимального остовного дерева взвешенного связного неориентированного графа. Количество различных путей между вершинами ориентированного ациклического графа. Алгоритм Дейкстры
3.15 Деревья. Реализация дерева с помощью ссылочных структур. Двоичные (бинарные) деревья. Построение дерева для заданного арифметического выражения. Рекурсивные алгоритмы обхода дерева. Использование стека и очереди для обхода дерева
Тип ответа:Краткий ответ
Номер: 896732
НЕ РЕШЕНО Ответить

Решение задания EGEINF896732

Ответ: 1713

Решение.
Прочитаем последовательность из файла 24.txt. Нужно найти самый длинный непрерывный фрагмент, в котором полностью не встречается сочетание XZZY. Отдельные буквы этого сочетания разрешены.
Просматриваем текст слева направо. Индекс right задаёт правый конец текущего фрагмента, а left — самый ранний допустимый левый конец. Индексы считаем с нуля. В начале left = 0.
Если последние четыре просмотренные буквы образуют XZZY, это запрещённое вхождение начинается в позиции right − 3. Чтобы оно не входило целиком в наш фрагмент, нужно исключить хотя бы его первую букву. Поэтому переносим левую границу в позицию right − 2.
Новая граница правее прежних запрещённых начал. Она исключает последнее вхождение и все предыдущие. Если нового вхождения нет, менять left не нужно. Следовательно, на каждом шаге получаем самый длинный допустимый фрагмент, заканчивающийся в right. Его длина равна right − left + 1.
Сохраняем максимум этих длин. Так учитываются также начало и конец файла; к крайним промежуткам нельзя автоматически прибавлять то же число букв, что и между двумя вхождениями.
Программа на Python 3:

with open('24.txt') as f:
    text = f.read().strip()

left = 0
best = 0
for right in range(len(text)):
    if right >= 3 and text[right - 3:right + 1] == 'XZZY':
        left = right - 2
    best = max(best, right - left + 1)
print(best)

Для исходного файла получаем 1713. В нём 1100000 символов и 8659 вхождений запрещённого сочетания. Один максимальный допустимый фрагмент занимает позиции с 725750 по 727462 включительно, если считать с единицы: 727462 − 725750 + 1 = 1713. Внутри него XZZY не встречается.
Проверка отдельным перебором промежутков между всеми запрещёнными вхождениями, включая оба края файла, подтверждает тот же максимум. Время работы O(L), где L — длина текста; чтение строки занимает O(L) памяти, дополнительные переменные — постоянный объём.
Ответ: 1713.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF896732.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.