Задание EGEINF733329: Выполнение и анализ программы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Выполнение и анализ программы.

Учебные темы: Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат.

Впишите правильный ответ.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 3, а потом 5.

Бейсик

Python

DIM X, L, M, Q AS INTEGER

INPUT X

Q = 6

L = 0

WHILE X >= Q

 L = L + 1

 X = X - Q

WEND

M = X

IF M < L THEN

   M = L

   L = X

END IF

PRINT L

PRINT M

x = int(input())

Q = 6

L = 0

while x >= Q:

    L = L + 1

    x = x - Q

M = x

if M < L:

    M = L

    L = x

print(L)

print(M)

Алгоритмический язык

Паскаль

алг

нач

  цел x, L, M, Q

  ввод x

  Q := 6

  L := 0

  нц пока x >= Q

    L := L + 1

    x := x - Q

  кц

  M := x

  если M < L

    то

      M := L

      L := x

  все

  вывод L, нс, M

кон

var x, L, M, Q: integer;

begin

  readln(x);

  Q := 6

  L := 0;

  while x >= Q do

  begin

    L := L + 1;

    x := x - Q;

  end;

  M := x;

  if M < L then

  begin

    M := L;

    L := x;

  end;

  writeln(L);

  writeln(M);

end.

Си

#include<stdio.h>

void main()

{

  int x, L, M, Q;

  scanf("%d", &x);

  Q = 6;

  L = 0;

  while (x >= Q){

    L = L + 1;

    x = x - Q;

  }

  M = x;

  if(M < L){

    M = L;

    L = x;

  }

  printf("%d\n%d", L, M);

}

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.1 Формализация понятия алгоритма. Машина Тьюринга как универсальная модель вычислений
Тип ответа:Краткий ответ
Номер: 733329
НЕ РЕШЕНО Ответить

Решение задания EGEINF733329

Ответ: 33

Цикл вычитает из x число Q = 6 и считает вычитания в L. После остановки исходное число X представляется как X = Q · L + r, где 0 ≤ r < Q; оставшееся x равно r.
Затем M получает остаток r. Если M < L, две величины переставляются, поэтому на выходе стоят меньшая и большая из частного и остатка: 3 и 5. Разберём оба возможных порядка.
Частное 3, остаток 5: ограничение остатка выполнено, X = 6 · 3 + 5 = 23.
Частное 5, остаток 3: ограничение остатка выполнено, X = 6 · 5 + 3 = 33.
Из всех допустимых вариантов выбираем наибольшее: 33.
Проверка: 33 = 6 · 5 + 3. После упорядочивания этих двух значений получаем именно 3 и 5. Других порядков для пары частного и остатка нет.
Перед последним вычитанием текущее x = 9 ≥ 6, поэтому проход выполняется. После него x = 3 < 6, следующий проход запрещён.
Итого выполнено 5 вычитаний. Условие перестановки сравнивает эти готовые частное и остаток, а исходное X после цикла уже не используется.
Ответ: 33.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF733329.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.