Задание EGEINF703256: Делители, маски и отбор чисел

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Делители, маски и отбор чисел.

Учебные темы: Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена».

Впишите правильный ответ.

Напишите программу, которая перебирает целые числа, бо́льшие 500 000, в порядке возрастания и ищет среди них такие, у которых есть натуральный делитель, оканчивающийся на цифру 9 и не равный ни самому числу, ни числу 9. В ответе запишите
в первом столбце таблицы первые пять найденных чисел в порядке возрастания, а во втором столбце – соответствующий минимальный делитель для каждого числа, оканчивающийся цифрой 9, не равный ни самому числу, ни числу 9.

Количество строк в таблице для ответа избыточно.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 703256
НЕ РЕШЕНО Ответить

Решение задания EGEINF703256

Ответ: (500002; 89), (500003; 71429), (500004; 19), (500007; 166669), (500013; 18519)

Решение.
Требуются первые пять чисел, строго больших 500000. Начинаем с 500001 и рассматриваем целые n подряд в порядке возрастания.
Для каждого целого d от 2 до ⌊√n⌋ проверяем остаток при делении n на d. При нулевом остатке добавляем d и парный делитель nd. Множество устраняет повторение в случае d² = n.
Это полный список делителей без 1 и n: в любой паре сомножителей хотя бы один не больше √n. Поэтому каждую пару находим, в том числе пары с большим вторым делителем.
Из полного списка оставляем делители с остатком 9 при делении на 10 и исключаем само число 9. Число n уже исключено при построении списка. Если подходящих делителей несколько, нужен наименьший, а не первый найденный парный сомножитель.
n = 500002: все разрешённые делители — 89, 2809.
Минимум равен 89; 89 · 5618 = 500002; 89 = 10 · 8 + 9.
89 отличается от 9 и от 500002.
n = 500003: все разрешённые делители — 71429.
Минимум равен 71429; 71429 · 7 = 500003; 71429 = 10 · 7142 + 9.
71429 отличается от 9 и от 500003.
n = 500004: все разрешённые делители — 19, 129, 969, 6579, 13889.
Минимум равен 19; 19 · 26316 = 500004; 19 = 10 · 1 + 9.
19 отличается от 9 и от 500004.
n = 500007: все разрешённые делители — 166669.
Минимум равен 166669; 166669 · 3 = 500007; 166669 = 10 · 16666 + 9.
166669 отличается от 9 и от 500007.
n = 500013: все разрешённые делители — 18519.
Минимум равен 18519; 18519 · 27 = 500013; 18519 = 10 · 1851 + 9.
18519 отличается от 9 и от 500013.
Полный последовательный перебор от 500001 до 500013 включительно проверяет 13 чисел. Условие выполняется ровно для пяти перечисленных n. Все меньшие допустимые кандидаты проверены, поэтому это именно первые пять чисел.
Проверка результата.
Воспроизводимая программа Python:

from math import isqrt

def proper_divisors(n):
    result = set()
    for d in range(2, isqrt(n) + 1):
        q, r = divmod(n, d)
        if r == 0:
            result.update((d, q))
    return sorted(result)

n = 500000
found = 0
while found != 5:
    n += 1
    d = proper_divisors(n)
    allowed = [x for x in d if x % 10 == 9 and x != 9]
    value = allowed[0] if allowed else 0
    ok = bool(allowed)
    if ok:
        print(n, value)
        found += 1

Результат: в каждой строке слева n, справа делитель.
500002 — 89
500003 — 71429
500004 — 19
500007 — 166669
500013 — 18519
Ответ: (500002; 89), (500003; 71429), (500004; 19), (500007; 166669), (500013; 18519).

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF703256.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.