Задание EGEINF6AB929: Обработка текстового файла

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Обработка текстового файла.

Учебные темы: Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Текстовый файл состоит из десятичных цифр и заглавных букв латинского алфавита. Определите в прилагаемом файле последовательность из максимального количества идущих подряд символов, среди которых ровно 45 нечётных цифр и при этом начинающуюся с буквы G, не содержащую других букв G, кроме первой.

В ответе запишите число – количество символов в найденной последовательности.

Для выполнения этого задания следует написать программу.

Скачать файл задания (TXT, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.9 Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно
Тип ответа:Краткий ответ
Номер: 6AB929
НЕ РЕШЕНО Ответить

Решение задания EGEINF6AB929

Ответ: 76

Решение.
В приложенном файле 10000000 символов данных. Рассматриваем непрерывные фрагменты строки; символы нельзя переставлять или пропускать. Сохраним приложенный текстовый файл под именем data.txt. Конечный перевод строки удаляем, остальные символы сохраняем.
Начало фрагмента должно принадлежать набору G; других символов из этого набора внутри быть не должно. Выпишем все такие позиции в starts и добавим длину строки как правую границу последнего участка.
Для каждого начала разрешено двигаться только до следующего символа из набора G. Внутри этого участка считаем символы из набора 13579. Нужно ровно 45 таких символов. Если их меньше, начало не подходит. Если встречается 46-й, заканчиваем непосредственно перед ним. Иначе берём весь участок до следующего запрещённого начала либо конца файла.
Это самый длинный допустимый фрагмент с данным началом: дальше находится либо лишний учитываемый символ, либо повторный символ начала. Все возможные начала перебраны. Участки не пересекаются, поэтому суммарный проход по ним линейный.
Программа:

import re

with open("data.txt", encoding="utf-8-sig") as f:
    s = f.read().rstrip("\r\n")
starts = [i for i, c in enumerate(s) if c in 'G']
starts.append(len(s))
answer = 0
for j in range(len(starts) - 1):
    left, right = starts[j], starts[j + 1]
    seen = 0
    end = right
    for i in range(left + 1, right):
        if s[i] in '13579':
            seen += 1
            if seen == 46:
                end = i
                break
    if seen >= 45:
        answer = max(answer, end - left)
print(answer)

Проверка результата. Нумеруем символы исходной строки с единицы. Один из оптимальных фрагментов имеет следующие границы:

ХарактеристикаЗначение
Первый символ9108575
Последний символ включительно9108650
Длина в символах76

Разность границ с учётом обоих концов: 9108650 − 9108575 + 1 = 76.
Начальный символ принадлежит набору G; других символов этого набора внутри нет. Символов из набора 13579 ровно 45. Подходящих начальных участков во всём файле 7040.
Полный проход по приложенному файлу даёт итоговый ответ. Проверка коротких строк полным перебором всех подстрок подтверждает обработку крайних случаев.
Ответ: 76.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF6AB929.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.