Задание EGEINF69BBBF: Эффективная обработка данных и кластеры

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Эффективная обработка данных и кластеры.

Учебные темы: Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность; Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых
файлов.

Для участников велогонки на каждом километре кольцевой трассы
с двусторонним движением установлены пункты питания. Длина кольцевой трассы равна N километров. Нулевой и N-й километры трассы находятся в одной точке. Известно количество комплектов питания в каждом из пунктов на трассе. В каждый пункт комплекты питания доставляет отдельный электрокар. Стоимость доставки питания вычисляется как произведение количества комплектов питания на расстояние от мобильного цеха их подготовки до пункта питания спортсменов на трассе. Мобильный цех подготовки комплектов расположен в одном из пунктов питания на трассе таким образом, что общая стоимость доставки из цеха во все пункты минимальна.

Определите минимальную суммарную стоимость доставки питания для спортсменов из цеха его подготовки в пункты питания на трассе.

 

Входные данные

Дано два входных файла (файл A и файл B), каждый из которых
в первой строке содержит число N (1 ≤ N ≤ 10 000 000) – количество пунктов питания на кольцевой трассе. В каждой из следующих
N строк находится число – количество комплектов питания на пункте (все числа натуральные, количество комплектов питания на каждом пункте не превышает 1000). Числа указаны в порядке расположения пунктов питания спортсменов на трассе, начиная
с первого километра.

В ответе укажите два числа: сначала значение искомой величины для файла А, затем – для файла B.

 

Типовой пример организации данных во входном файле

6

8

20

5

13

7

19

При таких исходных данных, если пункты питания установлены на каждом километре трассы, необходимо открыть мобильный цех подготовки комплектов питания для спортсменов в пункте 6.
В этом случае сумма транспортных затрат составит:

1 ∙ 7 + 0 ∙ 19 + 1 ∙ 8 + 2 ∙ 20 + 3 ∙ 5 + 2 ∙ 13.

 

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

Предупреждение: для обработки файла B не следует использовать переборный алгоритм, вычисляющий сумму для всех возможных вариантов, поскольку написанная по такому алгоритму программа будет выполняться слишком долго.

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.16 Динамическое программирование как метод решения задач с сохранением промежуточных результатов. Задачи, решаемые с помощью динамического программирования: вычисление рекурсивных функций, подсчёт количества вариантов, задачи оптимизации
Тип ответа:Краткий ответ
Номер: 69BBBF
НЕ РЕШЕНО Ответить

Решение задания EGEINF69BBBF

Ответ: 141530 18192010182272

Решение.

Обрабатываем два приложенных текстовых файла отдельно. В файле A содержится 110 записей, в файле B — 1200000. Заголовок задаёт параметры и не является элементом последовательности. Порядок исходных записей сохраняем. Числа из иллюстративного примера не заменяют данные файлов.

Нумеруем пункты от 0 до N − 1. Расстояние по кольцу между i и j равно min(|i − j|, N − |i − j|). Стоимость F(j) получаем суммированием количества груза aᵢ, умноженного на это расстояние. Сначала непосредственно вычисляем F(0).

Пусть h — целая часть половины N. При переносе центра на один пункт вперёд расстояния до h пунктов позади, включая старый центр, увеличиваются на 1; до h пунктов впереди уменьшаются на 1. При нечётном N остаётся один пункт, расстояние до которого не меняется. Храним суммы грузов increasing и decreasing в этих группах. Новая стоимость равна старой плюс increasing минус decreasing.

После сдвига обновляем обе суммы: из каждой группы выходит один пункт и входит один пункт. Индексы берём по модулю N, чтобы корректно перейти через начало кольца. Вместе с начальным центром выполняем N − 1 переходов и сравниваем все N стоимостей. Формула работает и для чётного, и для нечётного N; прямой пересчёт стоимости в найденном пункте проверяет итог.

Распакуем архив и положим указанные в программе текстовые файлы рядом с ней. Программа печатает результат для A, затем для B:

from array import array

def solve(name):
    with open(name, encoding="utf-8-sig") as f:
        n = int(f.readline())
        a = array("q", (int(f.readline()) for _ in range(n)))

    half = divmod(n, 2)[0]
    cost = sum(value * min(i, n - i) for i, value in enumerate(a))
    best = cost
    increasing = sum(a[i % n] for i in range(1 - half, 1))
    decreasing = sum(a[1:half + 1])
    for center in range(n - 1):
        cost += increasing - decreasing
        best = min(best, cost)
        increasing += a[(center + 1) % n] - a[(center - half + 1) % n]
        decreasing += a[(center + half + 1) % n] - a[(center + 1) % n]
    return best

print(solve('1_27_A.txt'), solve('1_27_B.txt'))

Время O(N), память O(N). Считывание и все арифметические действия выполняются над целыми числами; округление вычисленных ответов не требуется.

Проверка на исходных файлах. Номера элементов ниже отсчитываются от 1; полный алгоритм проверяет все допустимые варианты, а указанные позиции показывают достижение найденного результата.

ФайлПункт лабораторииОбщий грузСтоимость
A1055347141530
B9519906065878618192010182272

Для указанных пунктов стоимость дополнительно вычислена прямым суммированием кратчайших расстояний по кольцу. Независимый расчёт через удвоенную последовательность и взвешенные префиксные суммы дал тот же минимум.

Ответ: 141530 18192010182272.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF69BBBF.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.