Задание EGEINF3F3DF0: Делители, маски и отбор чисел

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Делители, маски и отбор чисел.

Учебные темы: Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена».

Впишите правильный ответ.

Пусть M – сумма минимального и максимального натуральных делителей целого числа, не считая единицы и самого числа. Если таких делителей у числа нет, то считаем значение M равным нулю.

Напишите программу, которая перебирает целые числа, бо́льшие 800 000, в порядке возрастания и ищет среди них такие, для которых M оканчивается на 4. В ответе запишите в первом столбце таблицы первые пять найденных чисел в порядке возрастания, а во втором столбце – соответствующие им значения M.

 

Например, для числа 20 М = 2 + 10 = 12.

 

Количество строк в таблице для ответа избыточно.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 3F3DF0
НЕ РЕШЕНО Ответить

Решение задания EGEINF3F3DF0

Ответ: (800004; 400004), (800009; 114294), (800013; 266674), (800024; 400014), (800033; 61554)

Решение.
Требуются первые пять чисел, строго больших 800000. Начинаем с 800001 и рассматриваем целые n подряд в порядке возрастания.
Для каждого целого d от 2 до ⌊√n⌋ проверяем остаток при делении n на d. При нулевом остатке добавляем d и парный делитель nd. Множество устраняет повторение в случае d² = n.
Это полный список делителей без 1 и n: в любой паре сомножителей хотя бы один не больше √n. Поэтому каждую пару находим, в том числе пары с большим вторым делителем.
Если список пуст, M = 0. Иначе берём его минимум p и максимум q, получаем M = p + q. Дополнительная проверка: q = np, поскольку при увеличении положительного делителя парный сомножитель уменьшается. Для квадрата простого числа минимум и максимум равны и складываются дважды.
Требуемое условие: остаток от деления M на 10 равен 4.
n = 800004: минимальный делитель 2, максимальный 400002; 2 · 400002 = 800004.
M = 2 + 400002 = 400004; 400004 = 10 · 40000 + 4.
n = 800009: минимальный делитель 7, максимальный 114287; 7 · 114287 = 800009.
M = 7 + 114287 = 114294; 114294 = 10 · 11429 + 4.
n = 800013: минимальный делитель 3, максимальный 266671; 3 · 266671 = 800013.
M = 3 + 266671 = 266674; 266674 = 10 · 26667 + 4.
n = 800024: минимальный делитель 2, максимальный 400012; 2 · 400012 = 800024.
M = 2 + 400012 = 400014; 400014 = 10 · 40001 + 4.
n = 800033: минимальный делитель 13, максимальный 61541; 13 · 61541 = 800033.
M = 13 + 61541 = 61554; 61554 = 10 · 6155 + 4.
Полный последовательный перебор от 800001 до 800033 включительно проверяет 33 чисел. Условие выполняется ровно для пяти перечисленных n. Все меньшие допустимые кандидаты проверены, поэтому это именно первые пять чисел.
Проверка результата.
Воспроизводимая программа Python:

from math import isqrt

def proper_divisors(n):
    result = set()
    for d in range(2, isqrt(n) + 1):
        q, r = divmod(n, d)
        if r == 0:
            result.update((d, q))
    return sorted(result)

n = 800000
found = 0
while found != 5:
    n += 1
    d = proper_divisors(n)
    value = d[0] + d[-1] if d else 0
    ok = value % 10 == 4
    if ok:
        print(n, value)
        found += 1

Результат: в каждой строке слева n, справа M.
800004 — 400004
800009 — 114294
800013 — 266674
800024 — 400014
800033 — 61554
Ответ: (800004; 400004), (800009; 114294), (800013; 266674), (800024; 400014), (800033; 61554).

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF3F3DF0.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.