Задание EGEINF3C7DD2: Выполнение и анализ программы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Выполнение и анализ программы.

Учебные темы: Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат.

Впишите правильный ответ.

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 5, а потом 6.

Бейсик

Python

DIM X, L, M AS INTEGER

INPUT X

L = 0

M = 0

WHILE X > 0

M = M + 1

IF X MOD 2 <> 0 THEN

 L = L + 1

END IF

X = X \ 2

WEND

PRINT L

PRINT M

x = int(input())

L = 0

M = 0

while x > 0:

    M = M + 1

    if x % 2 != 0:

        L = L + 1

    x = x // 2

print(L)

print(M)

Алгоритмический язык

Паскаль

алг

нач

  цел x, L, M

  ввод x

  L := 0

  M := 0

  нц пока x > 0

    M := M + 1

    если mod(x,2) <> 0

      то

        L := L + 1

    все

    x := div(x,2)

  кц

  вывод L, нс, M

кон

var x, L, M: integer;

begin

  readln(x);

  L := 0;

  M := 0;

  while x > 0 do

  begin

    M := M + 1;

    if x mod 2 <> 0 then

      L := L + 1;

    x := x div 2;

  end;

  writeln(L);

  writeln(M);

end.


 

С++

#include <iostream>

using namespace std;

 

int main()

{

  int x, L, M;

  cin >> x;

  L = 0;

  M = 0;

  while (x > 0){

    M = M + 1;

    if(x % 2 != 0){

      L = L + 1;

    }

    x = x / 2;

  }

  cout << L << endl << M <<endl;

  return 0;

}

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.1 Формализация понятия алгоритма. Машина Тьюринга как универсальная модель вычислений
Тип ответа:Краткий ответ
Номер: 3C7DD2
НЕ РЕШЕНО Ответить

Решение задания EGEINF3C7DD2

Ответ: 47

Каждый проход берёт остаток от деления текущего x на 2 и затем отбрасывает эту последнюю цифру целочисленным делением на 2. Поэтому M равно количеству цифр исходного числа в системе с основанием 2. Нужно ровно 6 цифр, первая из которых ненулевая.
Основание чётное, поэтому чётность текущего x совпадает с чётностью его последней цифры. Значит, L считает количество нечётных цифр. Начальное L = 0, требуемое конечное L = 5.
В двоичной записи должно быть 5 единиц и 1 нулей.
При одинаковой длине первым сравнивается старший различающийся разряд. Поэтому для минимума оставляем обязательную старшую единицу, затем ставим все нули, а оставшиеся единицы переносим вправо.
Получаем 101111 (основание 2). Перестановка, которая улучшала бы число, нарушит этот порядок или ведущую единицу.
Переведём запись в десятичную систему: 1 · 2⁵ + 0 · 2⁴ + 1 · 2³ + 1 · 2² + 1 · 2¹ + 1 · 2⁰ = 47.
Проверка: цифр 6, учитываемые цифры — 1, 1, 1, 1, 1. Их количество равно 5. Значит, программа выводит 5, затем 6.
Ответ: 47.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF3C7DD2.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.