Задание EGEINF37F79F: Выполнение и анализ программы

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Выполнение и анализ программы.

Учебные темы: Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат.

Впишите правильный ответ.

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 9, а потом 6. 

С++

Python

Алгоритмический язык

Паскаль

#include <iostream>

using namespace std;

 

int main()

{

  int x, a, b, c;

  cin >> x;

  a = 0; b = 0;

  while (x > 0) {

    c = x % 10;

    a = a + c;

    if (c > b)

      b = c;

    x = x / 10;

  }

  cout << a << endl << b << endl;

  return 0;

}

x = int(input())

a = 0

b = 0

while x > 0:

    c = x % 10

    a = a + c

    if c > b:

        b = c

    x = x // 10

print(a)

print(b)

алг

нач

     цел x, a, b, c

     ввод x

     a := 0; b := 0

     нц пока x > 0

       c := mod(x, 10)

       a := a + c

       если c > b

         то b := c

       все

       x := div(x, 10)

     кц

     вывод a, нс, b

кон

var x, a, b, c: integer;

begin

  readln(x);

  a := 0; b := 0;

  while x > 0 do

  begin

     c := x mod 10;

     a := a + c;

     if c > b then b := c;

     x := x div 10

  end;

  writeln(a); writeln(b)

end.

 



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.1 Формализация понятия алгоритма. Машина Тьюринга как универсальная модель вычислений
Тип ответа:Краткий ответ
Номер: 37F79F
НЕ РЕШЕНО Ответить

Решение задания EGEINF37F79F

Ответ: 36

Операции остатка и целочисленного деления на 10 последовательно выделяют десятичные цифры справа налево. Переменная a складывает все цифры, b хранит наибольшую из уже обработанных.
Требуется сумма цифр 9 и наибольшая цифра 6. Однозначное число невозможно, поскольку его единственная цифра должна одновременно равняться этим двум различным значениям.
Ищем двузначное число. Обе цифры не больше 6, одна из них равна 6. Чтобы уменьшить число, уменьшаем цифру десятков. При единицах не больше 6 десятки должны быть не меньше 9 − 6 = 3.
Эта нижняя граница достижима: десятки 3, единицы 6. Получаем 36. Любое трёхзначное или более длинное число больше него.
Проверка: сумма 3 + 6 = 9, наибольшая цифра 6. Программа выводит нужную пару.
Трассировка найденного числа:
Выделена цифра 6: a = 6, b = 6, оставшееся x = 3.
Выделена цифра 3: a = 9, b = 6, оставшееся x = 0.
Ответ: 36.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF37F79F.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.