Задание EGEINF361E52: Обработка текстового файла

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Обработка текстового файла.

Учебные темы: Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно.

Впишите правильный ответ.

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Текстовый файл состоит из заглавных букв латинского алфавита A, B, C, D, E и F.

Определите максимальное количество идущих подряд символов в прилагаемом файле, среди которых пара символов CD (в указанном порядке) встречается ровно 160 раз.

Для выполнения этого задания следует написать программу.

Скачать файл задания (TXT, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.9 Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно
Тип ответа:Краткий ответ
Номер: 361E52
НЕ РЕШЕНО Ответить

Решение задания EGEINF361E52

Ответ: 9712

Решение.
В приложенном файле 10000000 символов данных. Рассматриваем непрерывные фрагменты строки; символы нельзя переставлять или пропускать. Сохраним приложенный текстовый файл под именем data.txt. Конечный перевод строки удаляем, остальные символы сохраняем.
Выпишем в возрастающем порядке позиции начала всех вхождений CD. Обозначим этот список pos. Индексы в программе начинаются с нуля. Длина искомого сочетания равна 2.
Любой фрагмент, содержащий 160 вхождений, содержит последовательный блок из 160 элементов списка pos. Поэтому достаточно перебрать начала таких блоков.
Чтобы получить максимум для выбранных 160 вхождений, расширим фрагмент в обе стороны, не добавляя соседние вхождения. Если перед блоком есть вхождение в pos[i − 1], начинаем сразу после его первого символа: left = pos[i − 1] + 1. Если предыдущего вхождения нет, left = 0.
Если следующее вхождение начинается в pos[i + 160], заканчиваем перед его последним символом: правая невключённая граница right = pos[i + 160] + 1. Если следующего вхождения нет, right = len(s). Длина равна right − left. Так частичные сочетания на краях учитываются, а целое лишнее вхождение не попадает в фрагмент.
Здесь требуется ровно заданное количество, поэтому фрагменты с меньшим числом вхождений не рассматриваем. В исходном файле вхождений достаточно.
Программа:

import re

with open("data.txt", encoding="utf-8-sig") as f:
    s = f.read().rstrip("\r\n")
from array import array
pos = array("i", (m.start() for m in re.finditer('CD', s)))
k = 160
answer = 0
for i in range(len(pos) - k + 1):
    left = pos[i - 1] + 1 if i else 0
    right = (pos[i + k] + 1
             if i + k < len(pos) else len(s))
    answer = max(answer, right - left)
print(answer)

Проверка результата. Нумеруем символы исходной строки с единицы. Один из оптимальных фрагментов имеет следующие границы:

ХарактеристикаЗначение
Первый символ695353
Последний символ включительно705064
Длина в символах9712

Разность границ с учётом обоих концов: 705064 − 695353 + 1 = 9712.
В найденном фрагменте 160 вхождений CD. Во всём файле их 224680. Проверены все последовательные блоки нужного размера и крайние границы.
Полный проход по приложенному файлу даёт итоговый ответ. Проверка коротких строк полным перебором всех подстрок подтверждает обработку крайних случаев.
Ответ: 9712.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF361E52.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.