Задание EGEINF2EC6E2: Редактор и машина Тьюринга

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Редактор и машина Тьюринга.

Учебные темы: Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат; Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно.

Впишите правильный ответ.

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды заменить (111, 27) преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды заменить (v, w) не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

 

Цикл

ПОКА  условие 

         последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

ЕСЛИ  условие

     ТО команда1

     ИНАЧЕ команда2

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

Дана программа для Редактора:

НАЧАЛО

ПОКА нашлось (12) ИЛИ нашлось (322) ИЛИ нашлось (222)

    ЕСЛИ нашлось (12)

      ТО заменить (12, 2)

    КОНЕЦ ЕСЛИ

    ЕСЛИ нашлось (322)

       ТО заменить (322, 21)

    КОНЕЦ ЕСЛИ

    ЕСЛИ нашлось (222)

       ТО заменить (222, 3)

    КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

 

На вход приведённой выше программе поступает строка, начинающаяся с цифры «1», а затем содержащая n цифр «2» (3 <  n <  10 000).

Определите наибольшее возможное значение суммы числовых значений цифр в строке, которая может быть результатом выполнения программы.



i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
Тип ответа:Краткий ответ
Номер: 2EC6E2
НЕ РЕШЕНО Ответить

Решение задания EGEINF2EC6E2

Ответ: 17

Решение.
Начальное слово состоит из цифры 1 и n цифр 2. Начинаем с n = 4, поскольку n — целое и строго больше 3.
На каждом проходе условия ЕСЛИ проверяются по текущей строке сверху вниз. Следующая проверка учитывает изменения предыдущей команды. В конструкции с ИНАЧЕ выполняется только одна ветвь. Каждая замена затрагивает только первое слева вхождение.
Каждая выполненная замена уменьшает длину строки. За один проход цикла выполняется хотя бы одна замена, поэтому обработка любого выбранного n завершится.
Допустимые значения n: от 4 до 9999. Перебираем все допустимые значения (9996) и сохраняем наибольшую сумму цифр конечного слова. Воспроизводимый расчёт:

best = 0
for n in range(4, 10000):
    s = '1' + '2' * n
    while (
        '12' in s
        or '322' in s
        or '222' in s
    ):
        if '12' in s:
            s = s.replace('12', '2', 1)
        if '322' in s:
            s = s.replace('322', '21', 1)
        if '222' in s:
            s = s.replace('222', '3', 1)
    total = sum(map(int, s))
    best = max(best, total)
print(best)

Полный перебор даёт максимум 17. Он впервые достигается при n = 50; итоговое слово «221132132».
Контроль распределения: сумма 3 — 1784 значений n; сумма 4 — 1427 значений n; сумма 5 — 1075 значений n; сумма 6 — 714 значений n; сумма 7 — 1067 значений n; сумма 8 — 358 значений n; сумма 9 — 714 значений n; сумма 10 — 1424 значений n; сумма 11 — 4 значений n; сумма 12 — 713 значений n; сумма 13 — 356 значений n; сумма 14 — 2 значений n; сумма 15 — 356 значений n; сумма 16 — 1 значений n; сумма 17 — 1 значений n.
Число всех рассмотренных n равно сумме этих частот: 9996. Ни одной суммы больше 17 нет.
Проверка случая n = 50 по выполненным заменам:
12→2: число замен — 8.
222→3: число замен — 12.
322→21: число замен — 10.
По окончании цикла (число проходов — 13) получаем «221132132». Ни одна из цепочек 12, 322, 222 больше не встречается.
Сумма цифр этого слова: 1 · 3 + 2 · 4 + 3 · 2 = 17.
В ответ требуется сама наибольшая сумма, а не значение n: 17.
Ответ: 17.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF2EC6E2.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.