Задание EGEINF2B38DC: Поиск ошибок в программе

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Поиск ошибок в программе.

Учебные темы: Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования.

Дайте развернутый ответ.

На обработку поступает натуральное число, не превышающее 109. Нужно написать программу, которая выводит на экран количество цифр этого числа, делящихся на 3. Если в числе нет цифр, делящихся на 3, на экран требуется вывести «NO». Программист написал программу неправильно. Ниже эта программа для Вашего удобства приведена на пяти языках программирования.

Напоминание: 0 делится на любое натуральное число.

Бейсик

Python

DIM N, DIGIT, COUNT AS LONG

INPUT N

COUNT = 1

WHILE N > 0

  DIGIT = N MOD 10

  IF DIGIT MOD 3 = 0 THEN

    COUNT = COUNT + DIGIT

  END IF

  N = N \ 10

WEND

IF COUNT = 0 THEN

  PRINT "NO"

ELSE

  PRINT COUNT

END IF

N = int(input())

count = 1

while N > 0:

  digit = N % 10

  if digit % 3 == 0:

    count = count + digit

  N = N // 10

if count == 0:

  print("NO")

else:

  print(count)


 

Алгоритмический язык

Паскаль

алг

нач

  цел N, digit, count

  ввод N

  count := 1

  нц пока N > 0

    digit := mod(N,10)

    если mod(digit,3) = 0 то

      count := count + digit

    все

    N := div(N,10)

  кц

  если count = 0 то

    вывод "NO"

  иначе

    вывод count

  все

кон

var N, digit, count: longint;

begin

  readln(N);

  count := 1;

  while N > 0 do

  begin

    digit := N mod 10;

    if digit mod 3 = 0  then

      count := count + digit;

    N := N div 10;

  end;

  if count = 0 then

    writeln('NO')

  else

    writeln(count)

end.

С++

#include <iostream>

using namespace std;

 

int main()

{

  int N, digit, count;

  cin >> N;

  count = 1;

  while (N > 0)

  {

    digit = N % 10;

    if (digit % 3 == 0)

      count = count + digit;

    N = N / 10;

  }

  if (count == 0)

    cout << "NO" << endl;

  else

    cout << count << endl;

  return 0;

}

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе числа 145.

2. Приведите пример такого трёхзначного числа, при вводе которого программа выдаёт верный ответ.

3. Найдите все ошибки в этой программе (их может быть одна или несколько). Известно, что каждая ошибка затрагивает только одну строку
и может быть исправлена без изменения других строк. Для каждой ошибки:

1) выпишите строку, в которой сделана ошибка;

2) укажите, как исправить ошибку, т.е. приведите правильный вариант строки.

Достаточно указать ошибки и способ их исправления для одного языка программирования.

Обратите внимание на то, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. Исправление ошибки должно затрагивать только строку, в которой находится ошибка.


 

i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.6 Язык программирования (Паскаль, Python, Java, C++, C#). Типы данных: целочисленные, вещественные, символьные, логические. Ветвления. Сложные условия. Циклы с условием. Циклы по переменной. Обработка данных, хранящихся в файлах. Текстовые и двоичные файлы. Файловые переменные (файловые указатели). Чтение из файла. Запись в файл. Разбиение задачи на подзадачи. Подпрограммы (процедуры и функции). Использование стандартной библиотеки языка программирования
Тип ответа:Развернутый ответ
Номер: 2B38DC
НЕ РЕШЕНО Изменить статус

Решение задания EGEINF2B38DC

Ответ: 1) 1; 2) 101; 3) count = 0; count = count + 1

На обработку поступает натуральное число, не превышающее 10⁹. Нужно написать программу, которая выводит на экран количество цифр этого числа, делящихся на 3. Если в числе нет цифр, делящихся на 3, на экран требуется вывести «NO».

1. Выполнение исходной ошибочной программы.
Ввод: 145.
Шаг 1: N = 145, извлекается цифра 5; count = 1; после удаления последней цифры N = 14.
Шаг 2: N = 14, извлекается цифра 4; count = 1; после удаления последней цифры N = 1.
Шаг 3: N = 1, извлекается цифра 1; count = 1; после удаления последней цифры N = 0.
Вывод программы: 1.
Этот вывод относится именно к исходному коду. Требуемый по условию результат для тех же данных: «NO».

2. Пример, на котором исходная программа случайно даёт верный ответ.
Возьмём 101.
Шаг 1: N = 101, извлекается цифра 1; count = 1; после удаления последней цифры N = 10.
Шаг 2: N = 10, извлекается цифра 0; count = 1; после удаления последней цифры N = 1.
Шаг 3: N = 1, извлекается цифра 1; count = 1; после удаления последней цифры N = 0.
Вывод исходной программы: 1.
Подходящие цифры: 0. По условию получается 1, что совпадает с фактическим выводом.

3. Исправление ровно двух строк: Python.
Все остальные строки и отступы сохраняются.

Ошибка 1. Строка в исходной программе:

count = 1

Правильная строка:

count = 0

До обработки цифр найдено ноль подходящих цифр. Начальное значение 1 создаёт лишний результат даже тогда, когда подходящих цифр нет.

Ошибка 2. Строка в исходной программе:

    count = count + digit

Правильная строка:

    count = count + 1

Счётчик показывает количество подходящих цифр: каждая из них добавляет ровно 1. Значение цифры, в том числе нулевой, не определяет величину увеличения счётчика.

Проверка исправленной программы.
После обработки любого количества последних цифр накопленная переменная хранит количество подходящих значений этой части.
Вначале накопленное значение равно 0. Неподходящее значение ничего не меняет; подходящее увеличивает счётчик на 1. Это сохраняет утверждение после следующего шага.
После каждого шага последняя цифра удаляется целочисленным делением на 10. Положительное N уменьшается до 0, поэтому будут рассмотрены все цифры ровно по одному разу; при N ≤ 10⁹ требуется не более десяти шагов.
Счётчик равен 0 ровно при отсутствии подходящих цифр; заключительное ветвление выводит либо NO, либо найденное количество.
Для исходного ввода 145 исправленная программа выводит «NO».
Необходимость исправления 1: если оставить только эту ошибку, при вводе 1 получится 1 вместо «NO».
Необходимость исправления 2: если оставить только эту ошибку, при вводе 3 получится 3 вместо 1.

Ответ: 1) 1; 2) 101; 3) count = 0; count = count + 1.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF2B38DC.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.