Задание EGEINF2B1F8E: Обработка текстового файла

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Обработка текстового файла.

Учебные темы: Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно.

Впишите правильный ответ.

 

 Рисунок из условия ФИПИЗадание выполняется с использованием прилагаемых файлов.

 

Текстовый файл состоит из цифр 0, 7, 8, 9 и знаков арифметических операций «–» и «*» (вычитание и умножение). Определите максимальное количество символов в непрерывной последовательности, которая является корректным арифметическим выражением с целыми неотрицательными числами. В этом выражении никакие два знака арифметических операций не стоят рядом, в записи чисел отсутствуют незначащие (ведущие) нули и число 0 не имеет знака.

В ответе укажите количество символов.

Скачать файл задания (TXT, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.9 Обработка символьных данных. Встроенные функции языка программирования для обработки символьных строк. Алгоритмы обработки символьных строк: подсчёт количества появлений символа в строке, разбиение строки на слова по пробельным символам, поиск подстроки внутри данной строки, замена найденной подстроки на другую строку. Генерация всех слов в некотором алфавите, удовлетворяющих заданным ограничениям. Преобразование числа в символьную строку и обратно
Тип ответа:Краткий ответ
Номер: 2B1F8E
НЕ РЕШЕНО Ответить

Решение задания EGEINF2B1F8E

Ответ: 111

Решение.
В приложенном файле 10000000 символов данных. Рассматриваем непрерывные фрагменты строки; символы нельзя переставлять или пропускать. Сохраним приложенный текстовый файл под именем data.txt. Конечный перевод строки удаляем, остальные символы сохраняем.
Число без ведущих нулей — это либо отдельный 0, либо ненулевая цифра из набора 789, за которой идёт любое количество цифр из набора 0789. Поэтому шаблон числа: (?:0|[789][0789]*).
Корректное выражение состоит из числа, после которого идут ноль или более пар «операция, число». Допустимы только вычитание и умножение. Одиночное число тоже является выражением. Знаки не могут стоять в начале, в конце или подряд. Вычислять значение выражения не требуется.
Получаем шаблон (?:0|[789][0789]*)(?:[-*](?:0|[789][0789]*))*. Скобки (?:...) группируют часть выражения, звёздочка после группы разрешает любое количество повторений, в том числе ноль. Звёздочка внутри [-*] означает сам знак умножения.
Поиск выдаёт максимальное корректное выражение с каждого найденного начала. Начало внутри уже найденного корректного выражения может дать только его укороченный суффикс: оно не устраняет причину остановки на правой границе. Поэтому непересекающийся поиск не пропускает более длинный ответ. Если встретились ведущие нули, поиск может начаться с более поздней цифры; весь исходный файл не обязан быть одним корректным выражением.
Программа:

import re

with open("data.txt", encoding="utf-8-sig") as f:
    s = f.read().rstrip("\r\n")
pattern = '(?:0|[789][0789]*)(?:[-*](?:0|[789][0789]*))*'
answer = 0
for match in re.finditer(pattern, s):
    answer = max(answer, match.end() - match.start())
print(answer)

Проверка результата. Нумеруем символы исходной строки с единицы. Один из оптимальных фрагментов имеет следующие границы:

ХарактеристикаЗначение
Первый символ7319071
Последний символ включительно7319181
Длина в символах111

Разность границ с учётом обоих концов: 7319181 − 7319071 + 1 = 111.
Найденная подстрока полностью соответствует грамматике: все числа без ведущих нулей, между соседними числами ровно один разрешённый знак. Независимый посимвольный алгоритм с состояниями «ненулевая запись», «отдельный ноль», «операция» дал ту же максимальную длину.
Полный проход по приложенному файлу даёт итоговый ответ. Проверка коротких строк полным перебором всех подстрок подтверждает обработку крайних случаев.
Ответ: 111.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF2B1F8E.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.