Задание EGEINF12C4CF: Эффективная обработка данных и кластеры

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Эффективная обработка данных и кластеры.

Учебные темы: Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность; Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых
файлов.

У медицинской компании есть N пунктов приёма биоматериалов на анализ. Все пункты расположены вдоль автомагистрали и имеют номера, соответствующие расстоянию от нулевой отметки до конкретного пункта. Известно количество пробирок, которое ежедневно принимают в каждом из пунктов.

Компания планирует открыть лабораторию в одном из имеющихся пунктов. Перевозить биоматериалы разрешается на расстояние не более M. Пробирки перевозят в специальных транспортировочных контейнерах вместимостью не более 12 штук. Каждый транспортировочный контейнер используется для доставки пробирок только из одного пункта приёма, при этом из каждого пункта приёма может быть доставлено не более одного контейнера
с неполной загрузкой. Пункт для лаборатории выбрали таким образом, чтобы количество доставляемых туда контейнеров
с пробирками было максимальным. Определите необходимое количество контейнеров для доставки пробирок в эту лабораторию.

Входные данные

Даны два входных файла (файл A и файл B), каждый из которых
в первой строке содержит два числа N и M (1 ≤ N ≤ 10 000 000, 1 ≤ M ≤ 10 000 000) –  количество пунктов приёма биоматериалов
и максимальное расстояние, на которое разрешено перевозить биоматериалы. В каждой из следующих N строк находятся два числа: номер пункта и количество пробирок, принимаемых на этом пункте за сутки (все числа натуральные, количество пробирок
в каждом пункте не превышает 1000). Пункты перечислены
в порядке их расположения вдоль автомагистрали, считая от нулевой отметки.

В ответе укажите два числа: сначала значение искомой величины для файла А, затем –  для файла B.

Типовой пример организации данных во входном файле

6 3

1 100

3 200

6 4

7 3

8 2

10 190

При таких исходных данных и вместимости транспортировочного контейнера, составляющей 96 пробирок, компании выгодно открыть лабораторию в пункте 3. В этом случае количество контейнеров в ней составит: 2 + 3 + 1.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

Предупреждение: для обработки файла B не следует использовать переборный алгоритм, вычисляющий сумму для всех возможных вариантов, поскольку написанная по такому алгоритму программа будет выполняться слишком долго.

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 12C4CF
НЕ РЕШЕНО Ответить

Решение задания EGEINF12C4CF

Ответ: 332 27697

Решение.

Обрабатываем два приложенных текстовых файла отдельно. В файле A содержится 100 записей, в файле B — 1200000. Заголовок задаёт параметры и не является элементом последовательности. Порядок исходных записей сохраняем. Числа из иллюстративного примера не заменяют данные файлов.

Вместимость контейнера c = 12. Для пункта с t пробирками нужно w = ⌈tc⌉ контейнеров. В программе divmod даёт целую часть и остаток; прибавляем один, если остаток положителен. Округляем каждый пункт отдельно: объединять остатки из разных пунктов нельзя. Позиции x уже упорядочены по дороге.

Заголовок содержит N и M. Для лаборатории в существующем пункте x допустимы ровно позиции от x − M до x + M включительно. Суммируем их w; контейнеры самого пункта тоже входят, как показано в примере условия. Ищем максимум этой суммы, а не максимум числа пробирок и не минимум транспортной стоимости.

Два указателя ограничивают подходящий отрезок упорядоченных пунктов. Для очередного центра добавляем справа все xᵢ ≤ x + M, затем убираем слева все xᵢ < x − M. Текущее inside равно точной сумме весов оставшегося отрезка. При движении центра вправо обе границы могут только двигаться вправо. Каждый пункт добавляется и удаляется не более одного раза; проверяются все разрешённые места лаборатории.

Распакуем архив и положим указанные в программе текстовые файлы рядом с ней. Программа печатает результат для A, затем для B:

from array import array

def solve(name):
    capacity = 12
    x = array("q")
    w = array("q")
    with open(name, encoding="utf-8-sig") as f:
        n, distance = map(int, f.readline().split())
        for _ in range(n):
            position, tubes = map(int, f.readline().split())
            quotient, remainder = divmod(tubes, capacity)
            x.append(position)
            w.append(quotient + (remainder > 0))

    left = right = 0
    inside = best = 0
    for center in x:
        while right < n and x[right] <= center + distance:
            inside += w[right]
            right += 1
        while left < right and x[left] < center - distance:
            inside -= w[left]
            left += 1
        best = max(best, inside)
    return best

print(solve('308_27_A.txt'), solve('308_27_B.txt'))

Время O(N), память O(N). Считывание и все арифметические действия выполняются над целыми числами; округление вычисленных ответов не требуется.

Проверка на исходных файлах. Номера элементов ниже отсчитываются от 1; полный алгоритм проверяет все допустимые варианты, а указанные позиции показывают достижение найденного результата.

ФайлMЛабораторияПервая позицияПоследняя позицияКонтейнеров
A121306185406332
B1201152603785248371527238727697

Обе крайние позиции находятся не дальше M от лаборатории. Сумма контейнеров по всем строкам между ними совпала с результатом; независимый поиск границ двоичным поиском проверил каждый возможный центр.

Ответ: 332 27697.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF12C4CF.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.