Задание EGEINF0348F9: Эффективная обработка данных и кластеры

ФИПИ · ЕГЭ · все форматы ответа · 2475 заданий

Открыть решение ↓ Ошибка или пожелание

Тип задачи: Эффективная обработка данных и кластеры.

Учебные темы: Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность; Массивы и последовательности чисел. Вычисление обобщённых характеристик элементов массива или числовой последовательности (суммы, произведения, среднего арифметического, минимального и максимального элементов, количества элементов, удовлетворяющих заданному условию). Линейный поиск заданного значения в массиве. Алгоритмы работы с элементами массива с однократным просмотром массива. Сортировка одномерного массива. Простые методы сортировки (метод пузырька, метод выбора, сортировка вставками). Сортировка слиянием. Быстрая сортировка массива (алгоритм QuickSort). Двоичный поиск в отсортированном массиве.

Впишите правильный ответ.

Рисунок из условия ФИПИ

Задание выполняется с использованием прилагаемых
файлов.

 

У медицинской компании есть N пунктов приёма биоматериалов на анализ. Все пункты расположены вдоль автомагистрали и имеют номера, соответствующие расстоянию от нулевой отметки до конкретного пункта. Известно количество пробирок, которое ежедневно принимают в каждом из пунктов. Пробирки перевозят
в специальных транспортировочных контейнерах вместимостью не более 36 штук. Каждый транспортировочный контейнер упаковывается в пункте приёма и вскрывается только в лаборатории.

Компания планирует открыть лабораторию в одном из пунктов. Стоимость перевозки биоматериалов равна произведению расстояния от пункта до лаборатории на количество контейнеров
с пробирками. Общая стоимость перевозки за день равна сумме стоимостей перевозок из каждого пункта в лабораторию. Лабораторию расположили в одном из пунктов приёма биоматериалов таким образом, что общая стоимость доставки биоматериалов из всех пунктов минимальна.

Определите минимальную общую стоимость доставки биоматериалов из всех пунктов приёма в лабораторию.

Входные данные

Дано два входных файла (файл A и файл B), каждый из которых
в первой строке содержит число N (1 ≤ N ≤ 10 000 000) – количество пунктов приёма биоматериалов. В каждой из следующих N строк находится два числа: номер пункта и количество пробирок в этом пункте (все числа натуральные, количество пробирок в каждом пункте не превышает 1000). Пункты перечислены в порядке их расположения вдоль дороги, начиная от нулевой отметки.

В ответе укажите два числа: сначала значение искомой величины для файла А, затем – для файла B.

Типовой пример организации данных во входном файле

6

1 100

2 200

5 4

7 3

8 2

10 190

При таких исходных данных и вместимости транспортировочного контейнера, составляющей 96 пробирок, компании выгодно открыть лабораторию в пункте 2. В этом случае сумма транспортных затрат составит: 1 ∙ 2 + 3 ∙ 1 + 5 ∙ 1 + 6 ∙ 1 + 8 ∙ 2.

Типовой пример имеет иллюстративный характер. Для выполнения задания используйте данные из прилагаемых файлов.

Предупреждение: для обработки файла B не следует использовать переборный алгоритм, вычисляющий сумму для всех возможных вариантов, поскольку написанная по такому алгоритму программа будет выполняться слишком долго.

 

Скачать файл задания (ZIP, ФИПИ)


i
СВОЙСТВА ЗАДАНИЯ
КЭС:
3.2 Оценка сложности вычислений. Время работы и объём используемой памяти, их зависимость от размера исходных данных. Оценка асимптотической сложности алгоритмов. Алгоритмы полиномиальной сложности. Переборные алгоритмы. Примеры различных алгоритмов решения одной задачи, которые имеют различную сложность
3.3 Определение возможных результатов работы простейших алгоритмов управления исполнителями и вычислительных алгоритмов. Определение исходных данных, при которых алгоритм может дать требуемый результат
3.4 Алгоритмы обработки натуральных чисел, записанных в позиционных системах счисления: разбиение записи числа на отдельные цифры, нахождение суммы и произведения цифр, нахождение максимальной (минимальной) цифры. Представление числа в виде набора простых сомножителей. Алгоритм быстрого возведения в степень. Поиск простых чисел в заданном диапазоне с помощью алгоритма «решето Эратосфена»
3.5 Многоразрядные целые числа, задачи длинной арифметики
Тип ответа:Краткий ответ
Номер: 0348F9
НЕ РЕШЕНО Ответить

Решение задания EGEINF0348F9

Ответ: 51063 5634689219329

Решение.

Обрабатываем два приложенных текстовых файла отдельно. В файле A содержится 100 записей, в файле B — 1100000. Заголовок задаёт параметры и не является элементом последовательности. Порядок исходных записей сохраняем. Числа из иллюстративного примера не заменяют данные файлов.

Вместимость контейнера c = 36. Для пункта с t пробирками нужно w = ⌈tc⌉ контейнеров. В программе divmod даёт целую часть и остаток; прибавляем один, если остаток положителен. Округляем каждый пункт отдельно: объединять остатки из разных пунктов нельзя. Позиции x уже упорядочены по дороге.

Стоимость для лаборатории в x равна F(x) = Σ wᵢ · |xᵢ − x|. Если сдвинуть её вправо между соседними пунктами на d, стоимость изменится на d · (Wлев − Wправ): путь слева удлинится, справа укоротится. Поэтому стоимость убывает, пока справа больше половины всех контейнеров, и возрастает, когда слева больше половины.

Выбираем первый пункт, где накопленная сумма контейнеров не меньше половины общей: проверяем 2 · накопленная ≥ общая без округления. В этой взвешенной медиане с каждой строгой стороны не больше половины веса; это обеспечивает минимум. При равенстве возможен целый промежуток минимумов, но выбранный существующий пункт допустим. После выбора позиции один раз суммируем wᵢ · |xᵢ − x|. Пробирки самого пункта дают нулевую стоимость.

Распакуем архив и положим указанные в программе текстовые файлы рядом с ней. Программа печатает результат для A, затем для B:

from array import array

def solve(name):
    capacity = 36
    x = array("q")
    w = array("q")
    with open(name, encoding="utf-8-sig") as f:
        n = int(f.readline())
        for _ in range(n):
            position, tubes = map(int, f.readline().split())
            quotient, remainder = divmod(tubes, capacity)
            x.append(position)
            w.append(quotient + (remainder > 0))

    total = sum(w)
    accumulated = 0
    for i, weight in enumerate(w):
        accumulated += weight
        if 2 * accumulated >= total:
            center = x[i]
            break
    return sum(weight * abs(position - center) for position, weight in zip(x, w))

print(solve('301_27_A.txt'), solve('301_27_B.txt'))

Время O(N), память O(N). Считывание и все арифметические действия выполняются над целыми числами; округление вычисленных ответов не требуется.

Проверка на исходных файлах. Номера элементов ниже отсчитываются от 1; полный алгоритм проверяет все допустимые варианты, а указанные позиции показывают достижение найденного результата.

ФайлПункт лабораторииВсего контейнеровСтрого слеваСтрого справаСтоимость
A56320810310451063
B49955212254845112742011274225634689219329

Удвоенный вес каждой строгой стороны не превосходит общего веса. Прямая сумма стоимости по всем пунктам даёт число в последнем столбце; независимый пересчёт изменений стоимости между соседними пунктами подтверждает минимум.

Ответ: 51063 5634689219329.

Помочь улучшить сайт

Напишите пожелание к сайту или решению либо сообщите о найденной неточности в задании EGEINF0348F9.

Сообщение увидит только команда сайта: на странице оно не публикуется.

Комментарии к решению

Комментарии видны всем посетителям сайта.

Комментариев пока нет. Будьте первым.

Чтобы оставить комментарий, войдите или зарегистрируйтесь.